Cant add widgets in 3rd party launchers

monalacmonalac Level 2
edited June 29 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: rog 5s
  2. Firmware Version: a12 31.0810.1226.77
  3. Rooted or not: not
  4. Frequency of Occurrence: always
  5. APP Name & APP Version (If your issue relates to the app): nova launcher widgets

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


Cant add widgets in nova launcher or any third party launchers.

Pls fix this of share a workaround.


  • Hi monalac,

    As you mentioned which 3rd Party launcher are you using? 

  • monalacmonalac Level 2

    Hello, widgets doesn't work on Nova Launcher, Nothing Launcher beta, Launchair. Ive tried all three. When I add widget message comes of systemui shutdown.

    Pls help asap. Feels bad experience without using widgets since 2 weeks.

    Note that other rog5 users also are facing this issue. Its a common problem / bug. Pls share a workaround for this.

  • Omkar13579Omkar13579 Level 1

    yep exactly the same issue as me @ARP_ASUS

  • KyLL3R666KyLL3R666 Level 1

    Hello, i'm experiencing the same issue, i've tried Nova launcher and lawnchair, i get a message that settings has stopped working.

    I'm using the Rog Phone 5s Pro, i did not encounter this problem until my phone died a few weeks ago and i sent it to a service. They replaced the motherboard and now everything works fine except the widgets.

  • KyLL3R666KyLL3R666 Level 1

    Hello, i'm back here to say that my phone just got an update and now the widgets can be placed again so the problem is probably fixed. Tried on nova launcher and it works just fine.

  • Omkar13579Omkar13579 Level 1

    I can second the fact that that issue has been fixed for me atleast on Nova launcher

  • monalacmonalac Level 2

    Yes. Issue fixed of widget. Phone now looks complete

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.