Asus Rog 5 65w charge stopped working this morning

janisvg19janisvg19 Level 1
edited June 22 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name:
  2. Firmware Version:
  3. Rooted or not:
  4. Frequency of Occurrence:
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


Hei my 65w charge stopped working this morning.

Now I am using asus cable and another charger . So phone is charging now on different charge .

I am using the Rog cable and different charging head.

So cable is ok


But when I charge different phone whit the Rog charge then it Charging.

So maybe software on my phone is not okey or .

I have restarted the phone .


  • janisvg19janisvg19 Level 1

    Now it is working I trayed whit different 65 w charge . To charge it worked . And the I tried whit orginal Rog 65w charge it started to work again

  • randiahmrandiahm Level 1
    edited May 23

    I Have A Same Problem Here It Didnt Charge Fast Charging, 23 May 22 This Morning🙏

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.