UX325JA wrong PD firmware installed, battery not working

patrykmonkeypatrykmonkey Level 1
edited June 16 in ZenBook
  1. System: Windows 10
  2. Battery or AC: AC
  3. Model: UX325JA.309
  4. Frequency of occurrence: Always
  5. Reset OS: Yes
  6. Screenshot or video:


Detailed description:

I inadvertently installed this PD firmware update (dlcdnets.asus.com/pub/ASUS/nb/UX425EA/PD_FWUpdater.exe) on my UX325JA after finding it on the support site and mistaking it with this model:

Zenbook 13 UX325 (11th Gen Intel)|Laptops For Home|ASUS Global

Now my battery is not working at all. Zenbook only works plugged in, battery shows constant charge of 26%. I want to revert back to the original PD firmware for UX325JA but I cannot find it on the support site for my actual model:

Zenbook 13 UX325|Laptops For Home|ASUS Global

 I tried numerous things to resolve this, using default bios, resetting os etc, but it seems I need the original firmware to resolve this. Please help. I see I am not the first person to experience this:

UX425JA Power Delivery Firmware — ZenTalk (asus.com)

It is unacceptable that ASUS provides software firmware updates that do not check for model compatibility. Now I have a useless laptop after one year since buying.


  • method 1.

    go to device manager , uninstall battery related drivers only two, after that restart windows, see if issue is fixed ornot ,

    if not means go to second method

    method 2

    I don't have your model laptop. try to find the following files , these might be residing any folder ,





    and then note down the location of theeach file, where is located ,

    copy each file to some other drive say E:\backup folder

    and then delete those files,after restart the device , if problem is fixed means , issue solved

    if issue is not solved, you need to contact the asus service center.

  • method 1 did not work. I only see "Microsoft ACPI-Compliant Control Method Battery", I do not see the second one which I think should be "Microsoft AC Adapter"

    method2 did not work either. I tried doing a clean install of windows 10, to wipe all those files but still battery not charging, and zenbook only works plugged in.

    How do i contact asus service out of warranty? I will still try to unplug battery and plug back in. All I need is the original firmware I think.

  • @patrykmonkey

    According to what you described, please contact ASUS repair center in the country of your residence: https://www.asus.com/support/Service-Center-All-Countries/. Sorry for any inconvenience it may be caused. 

  • patrykmonkeypatrykmonkey Level 1
    edited May 17

    The PD utility which asus provide for UX325EA/UX425EA CCG5FWUpdate.exe comes with a few options. I'm not sure if it actually did try to update the PD FW on my UX325JA since all that happens is that the laptop shuts down immediately when I run the install script (CCG5FWUpdate.exe /W_FW cfg_2.bin) . No output, laptop just shuts down. The only option that provide some output is /R_VER and I see PD_FW_Ver: 51 , is that the correct PD FW for UX325JA ? There's also an option to read the current PD FW binary, but it returns nothing for me. If someone with a working UX325JA can execute these commands, and recover the original FW binary please post here. Asus support is not able to help, even though it was their support site that provided this faulty software.

  • okna2003okna2003 Level 1

    Have you tried using the MyASUS app? It allows you to get the original BIOS from the asus website and use it.

  • Yes, I tried bios flash and windows clean install. It doesn't help because it's the USB type C port controller PD firmware chip that has issues, not the bios. The asus support site only has PD firmware for the EA models, not JA, and nobody at asus support can provide the original JA firmware. I will try to reseat the battery next. Not much else I can try anymore.

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.