Notification light doesn't notify

pedalblimppedalblimp Level 1
edited May 21 in ZenFone 8

I have recently bought a Zenfone 8 and am trying to set it up. The notification light works when I'm charging the phone, but doesn't light up for anything else, including SMS and WhatsApp. I have definitely set the notification LED setting to on, and switched on the option to blink when receiving notifications. Following other bug reports here I've tried setting the notification to have a tone rather than be silent, even though I'd prefer silence, and that doesn't work either. I was using Durable battery mode, but tried changing that to Advanced and still don't get a light. What else can I try?

Comments

  • Just to recap, have you gone into "Display" then into "LED Indicator" (before you toggle it to on) as there are two options in there one to "Light up when charging" and "Flash when Notification arrives"?

  • Yes, I've definitely gone into the LED indicator setting and switched both options on. I've also set the setting in WhatsApp to use the notification light, and chosen colours I know the LED can make because they're colours the charging light makes, and set it to make a sound on notification. I'm getting the sound now (I had to remove the app from battery control, because somehow 'control background use' seems to be considered a reason to stop a communications app from communicating) but still no light.

  • With messages make sure you have all the "suggestions" options turned off. I noticed if you leave any of these options on the notification light won't work.

    With whatsapp you will need to go each chat option and select notification light to be on

  • I have already enabled the light option for single and group chats - is there some other option apart from those?

  • Try to reset your phone

    Maybe there are some bugs on it

  • I've only had the phone a week... And if there's bugs in the software, resetting won't change that software, will it?

    (Does anyone from Asus tech support ever comment on this board, or are we all just working it out for ourselves?)

  • Resetting won't fix it

    You need the following settings to make it work in messenger and whatsapp


  • Thanks for that - those are the settings I've got for WhatsApp and SMS, though, apart from using a sound for WhatsApp rather than silence, and that still doesn't get me a notification light.

    What's the top screenshot from? I can't seem to find that screen anywhere, so maybe that's the one I'm missing...

  • MrAvengerMrAvenger Level 2
    edited April 20

    one of those is for the google messenger program. with the whatsapp settings..make sure you go through and reselect all the other options one after another eg notification tone, vibrate, light. also double check the notification settings have blink light enabled in the settings/apps & notification --whatsapp/notification/group notifications and message notifications.


    with the whatsapp group notification you will have to go to the group and override the notification by selecting custom notifications (first screen shot)

  • Okay, I think that might have sorted it out for WhatsApp - as well as changing the overall Settings of the app, looks like I have to go into each chat (individual ones as well as group chats), click on the person or group's name (not the three dots I'd assumed any settings would be under) and then set that chat to use 'custom' notifications... What's the point of the Settings section if it doesn't set the settings? 🤣🤣 Still, might have got there eventually 😆😆

  • Yep that's exactly each group needs a custom notification but each person shouldn't. That's how I have it set up on mine.

This discussion has been closed.