tuf a15 fa506iv - acpi bios error (bug): could not resolve symbol

aumhrenaumhren Level 1
edited May 12 in Others


win10pro, latest, gratest

tuf a15 fa506iv (2020) comp

bios 318, 2022-02-23

i am trying to live boot linux mint

power on, f2 into bios, f8 boot order, select usb linux mint, enter

(working, please wait ... lol)

i get error:

acpi bios error (bug): could not resolve symbol [\_SB.PCIO.GPP4.WLAN], AE_NOT_FOUND (20190816/dswload2-162)

acpi error: ae_not_found, during name lookup/catalog (20190816/ps object-220)


failed to load kernel channel, -zz

not sure if it is linux mint thing, or asus tuf a15 bios ?

will try to live boot ubuntu, see what happens

please advise

best regards



i guess i should specify that linux mint does not start at all, i need to kill it with power button (hold - off)

if i reboot normally, windows work ok


ubuntu initially gives same error (i had a glimpse, screen changed quickly)

but was able to boot up, live usb


  • Hi there,

    When coding BIOS, it's based on Windows environment.

    We will support to ensure BIOS can ensure Windows work OK.

    But for Linux, because it's open, we are not guarantee the BIOS can support.

    Please remove the Linux and keeps only in Windows OS, then try to see the issue persists or not.

    Thank you.

  • aumhrenaumhren Level 1

    ok, nvidia drivers were (common) cause

    dl linux that uses proprietary nvidia drivers

    works fine

    case solved

    have fun


This discussion has been closed.