Airtrigger not working. Fingerprint sensor not detected.

edited May 4 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: ROG 5
  2. Firmware Version: latest.
  3. Rooted or not: Not rooted.
  4. Frequency of Occurrence: Airtrigger dosent register touch ( very frequent) Fingerprint sensor not detected ( 2 months)
  5. APP Name & APP Version (If your issue relates to the app): Game Genie.

1. The main feature of the phone and the main reaso why I bought this ROG 5 was the Airtrigger. Game Genie runs fine but the Airtrigger don't register touch hence it is unresponsive. Even after 3 - 4 restarts it still doesn't work. It is extremely frustrating.

2. The fingerprint sensor is not detected as a result there is no fingerprint option in security. The fingerprint option is not at all available in the security section as you can see in the screenshot

Attaching the screenshot.



  • rStarrStar Level 2

    Fingerprint option is unavailable since .229 update or before?

    Backup data and factory reset your phone.


    Hi rStar,

    The Fingerprint option is unavailable since the past 2 months. I can live without the Fingerprint print but Air trigger is what I can't do without.

    I already performed the factory reset 3 times in the past week dosent help with the fingerprint or the air trigger.

  • rStarrStar Level 2

    Ohh... Then take it to service centre, they'll assist you better

    Air trigger was in my mind too when i decided to buy it

    edited March 15

    Hi GYABAK,

    You can run SMMI test to check fingerprint hardware issue.

    How to Enter SMMI_TEST (test hardware)

    Go to Calculator=>type " .12345+= "

    you will be entered to SMMI_TEST

    Also, if you have tried all the troubleshooting please visit the nearest service center:

    Kindly visit the nearest service center:


    Thanks guys. I visited the service centre. And the problem was solved within hours. They worked on it both on hardware as well as software level.

  • 1114353911143539 Level 1

    I am facing same problem in my phone

This discussion has been closed.