ASUS TUF F15 Wifi MediaTek MT7921 issue, it keeps disconnecting and crashing causing BSOD

edited May 29 in Others
  1. System: Windows 10/11
  2. Battery or AC: Both
  3. Model: Asus TUF F15
  4. Frequency of occurrence: frequently
  5. Reset OS: Done
  6. Screenshot or video:


Detailed description: Wifi is malfunctioning, it works and suddenly goes blank for some 2-3 mins and comes back online, blank means in a state where it is unaccessible, where it is disconnected and any attempt to connect again is useless, after some 2-3 mins it comes back online and then it works fine for again some 40-60 mins and the cycle repeats. Also sometimes it keeps crashing giving BSOD when checking DUMP files it shows the issue is with the wifi Driver. I tried to get the latest wifi driver from Asus Support's official website but the issue is not solved yet. It's too much annoying when doing serious work and the laptop is just 3 months old

Things I did :

1) Updated to the latest version of driver 'MediaTek 802.11AX Wireless Adapters'

2) Rested the entire windows

3) BIOS also updated and has default settings


I have seen many people getting this issue in this thread:

So can I get a proper step-by-step solution if this is a software issue.

This I posted a few days back, but the issue is still not solved, I brought this laptop online from amazon. I contacted Asus Customer Support, they said they will send a service Engineer home for a checkup within 2 days once you receive mail, I got the mail but now it's been 5 days nothing from the Asus-side, that engineer has not shown up, and now as colleges are reopening across India I need to go to my college within next few days which is in a different city. Having spent more than 1 Lakh rupees on this machine and getting such problems is seriously disappointing.

The case is registered with case ID: A2203037293-0001




  • Hi there,

    May I know your model name?

    I know you tried update driver 'MediaTek 802.11AX Wireless Adapters' to the latest version.

    Is it V3.00.01.1207?

    Here I would like you try below:

    1. please download the new version
    2. go to device manager>find "MediaTek 802.11AX Wireless Adapters">right click and chose "properties">chose "uninstall device(U)">make sure you check on the "delete driver of this device" then uninstall device
    3. install the new version

    Also, I will check with local regarding onsite service.

    Thank you.

  • yes it is V3.00.01.1207

    Regarding the solution you told sir, I have already tried it. The issue is still there.

    Whenever I delete and install the driver again, the issue is stopped for some 3-4 hrs, but it happens again

    I am from Satara Maharashtra

    pin : 415002

  • Hi there,

    Looks like you have tried troubleshooting steps.

    It looks like may some hardware issue.

    I already ask local service center contact you ASAP for your onsite service.

    Thank you.

  • moriznamorizna Level 1

    I have exactly the same issue. Already tried the same troubleshooting suggested here.

    ~ Rizuan (Malaysia)

  • Hi there,

    If you also tried above troubleshooting steps but the issue persists, I would suggest you contact the service center to do further inspection.

    Thank you.

  • Chirag MakwanaChirag Makwana Level 1
    edited April 19

    Hi there,

    I bought Asus Tuf 15 - FX506LH in Dec, 2021,

    Till Date it's working fine, from last 3-4 Days I am facing issue with WiFi connectivity, it's frequently dropped and cont. dropping, I have checked my other device with speed test, all working fine, just facing with this Laptop. I have tried many solution but not succeed. Even after reset network connection it isn't working,

    I have found on solution so, Today i have tried with the network property change to 802.11ac from 802.11ax. let see if this solution work or not. let hope for good.


  • I also have the same problem with my Asus tuf gaming f15 and when I try to troubleshoot then it is showing that the default gateway is not found.

    moreover, my Bluetooth driver is also not working properly, whenever I change the position of my laptop it disconnects from my headphone and went to the blank state where I'm unable to connect my Bluetooth again for 2-3 minutes.

  • Hi @utsav0724 ,

    Please refer to above steps try to uninstall and reinstall the latest driver.

    You can download driver ib below link:

    ASUS TUF Gaming F15 - Support

    Also, you can use MyASUS to do diagnosis.

    [Notebook] MyASUS - Customer Support | Official Support | ASUS Global

    Thank you.

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.