Major problems with Android Auto

TheArcaneTheArcane Level 1
edited March 1 in ZenFone 8

I have a 2021 Peugeot 3008 and I have major problems using Android Auto with the Zenfone 8.

The car has a type-A USB port, so I can't use the original cable provided with the phone.

I went through 5 or 6 different cables already, most of them do nothing at all. Starting from old cables I can't even remember from which device, through a brand new cable rated for 10GBps data rate. For most of them Android Auto doesn't launch at all and the car may or may not say "device not recognized" or something of the sort.

The best result is with an original cable from a OnePlus Nord 2. With that cable Android Auto launches and works, but after 10-20 minutes it disconnects and doesn't connect again until I reset the phone and/or the car head unit. Didn't experiment enough with this yet.

Does anyone have a similar experience and maybe a solution? Is my phone broken or should I keep looking for a cable that works? I'm really disappointed as this is a complete deal breaker for me...

Thanks for any advice...


  • Don't have a 3008, but I've been using this one from AliExpress without any trouble with our Peugeot e-208. The port doesn't provide a lot of power though. Think it was 0,5 amp at 5v, so for the most part it just maintains the battery while using GPS.

    Edit: couldn't post link, so here in plaintext

  • I'll try it, thanks... Did you try other cables that didn't work?

  • I used to have AA issues with Android 11 (the AA would repeatedly connect and disconnect irrespective of cable, then suddenly work fine; the behavior was confirmed by others as well). Ever since I moved to Android 12 beta I have no longer any issue (with any cable).

  • Using some cables I had laying around in the beginning I did have connection problems (that was a different phone though). Seemed like the contact wasn't good and it dropped on and off. Still running Android 11 here.

  • Hey. I had those problems as well. It happens to me if my screen is shut down. I just downloaded an app to keep my screen awake as the maximum duration is 10 minutes. It helped me. Hope this helps you.

  • I updated to official android 12 and everything's the same. The one cable that works at all only lasts for ~20m. I turned off battery optimization for AA and that didn't work either. Waiting for the cable from AliExpress that was recommended here, but pretty hopeless TBH. Don't understand how it can be such a mess ..

  • I have no explanation then. A mismatch with the car's console?

  • Willem_NLWillem_NL Level 1
    edited January 5

    Same here, Peugeot with Wave2 NAC has compatibility issues with the Zenfone 8. Other phones as Samsung, Sony and Xiaomi works fine. Problem exists with A11 and official A12 (no beta) releases. Strange is that even when I disable the Android Auto app, the problem still exists. Look likes a compatibility issue with the Zenfone 8 USB port/protocol. Hopefully can/will Asus fix this soon, it's very annoying....

  • Today I tried a lot of USB cables, and only one look likes to fix the problem. I tried for short time, so no duration test done yet.

    Look likes that the Zenphone and Peugeot/Continental NAC combination have a very sensitive interface. All cables do work with Zenfone connected to a PC, but also with other (non-Zenfones) in this Peugeot. So the issue is very specific for the Peugeot NAC & Zenfone 8 combination.

    This makes me think it's an electrical or timing issue. This combination seems to be very sensitive to the transmission line characteristics of the USB cable. Especially because the problem also occurs when the Android Auto app is disabled on the Zenfone. This is the first time I've seen a combination of devices so sensitive to the USB cable used. Hopefully Asus or Peugeot can improve it with a software update.

  • --- SOLUTION ---

    As you can read in other posts of me in this thread, I did an investigation to this problem and found a reasonable solution. By using a USB 2.0 hub you can get around the problem

    It seems to me that the Android Auto problem with the Zenfone 8 and Peugeots and other PSA cars occurs due to an electrical issue such as transmission line characteristics.

    By placing a USB 2.0 hub between the car and telephone, the data connection is electrically interrupted. The hub acts as an intermediary between telephone and car. DO NOT connect more devices to the hub at the same time. Your car is not designed to connect multiple devices at the same time. The hub's sole purpose is to clean the electrical signal between phone and car.

    My advice is to use a USB2.0 hub and not higher versions of the USB standard. Higher versions of the USB standard may cause similar problems as a direct-connected phone. This is because higher speeds require much more critical timing.

    Although almost all of these small hubs get their power from the USB port, it is wise to be careful not to buy a hub that requires an external power supply, as you normally do not have 230VAC in your car.

    This is the USB2.0 hub that I have tested successfully:

    I expect that you can get around the problem with other USB2.0 hubs as well.

  • Thanks! Will definitely try that.

  • I have found that with one of my cables - an original Google PD USB cable - the Z8 works flawlessly if I insert the cable one way, but keeps disconnecting if I insert it the other way. So the USB interface is a bit iffy.

  • kzmkzm Level 1

    This sounds like a bug in Zenfone8... is it @Irene2_ASUS ?

  • That conclusion is a bit premature. It looks like a timing problem on the USB bus. You will have to measure with special equipment who is causing the timing issue. It is a collaboration between two devices, it is impossible to say in advance who will go wrong with timing.

    So it can be the Zenfone, but also the car. In addition to timing, impedance mismatch can also be the cause. Due to the high speeds, a USB connection is very prone to errors.

    Fortunately, there is a work arround for this problem with the USB hub.

  • My car works with the same cable (and a few others), whichever way I insert it, with the Pixel 5, Samsung S10e, Sony XZ1 Compact and Xiaomi Mi Max 3. But not with the Zenfone 8, which also has issues with other cables (same car) - and other cars. The conclusion is not really premature, but comes after lot of anecdotal data. I don't know what causes the USB-C issues on the Z8, but it stands alone, so to speak.

  • Did the trick with the USB hub offer a solution, or did you not test it?

  • Didn't test it. My dad gave me his original cable from a OnePlus Nord 2 and it seems to work. Of course, my own original Nord 2 cable was the one that disconnected after 20m so go figure... I may also be helping that I got a phone mount in case I have to give up AA entirely, and I keep it in the mount instead of sliding around in some cubby...

  • zyga2zyga2 Level 1

    @Willem_NL It did the trick for me. I had exactly same continous android auto restarting issue with my Suzuki SX4 and connecting USB hub resolved problem. Thank you.

  • Im facing charging issue while connected to usb-a port in my mazda cx-30 (zf8). The phone is not charging at all with android auto connection. Sometimes 1% up. How to fix this. The phone is also very problematic with cables. I'm using hama 5.0A PD (15 cm) usb-a to usb-c and it works (aa connection) but any of tested cables gave me charging effect...

  • RoystoysRoystoys Level 4
    edited January 29

    I have a similar issue with the zenfone 7, the only cable that works is an expensive Anker short 30 cm cable. All my cables used to work so I'm not sure if it is a phone issue or an android auto bug. The really strange thing is that AA works fine with my Telstra prepaid SIM card but not with my Vodafone Sim card but it all used to work perfectly with Vodafone until a recent ( a couple of months now) update. I spoke with Vodafone customer service and he said that they have been getting a lot of calls and suggested that Asus have changed something in the settings and thats what is the cause but I don't know if he is right or not . I do know that it's a much larger problem than you would think,if you google the issue you need a day to read all the results and it's all phones not just Asus so who the hell knows what is going on?

This discussion has been closed.