A problem to login to Zentalk via zenphone 8

MalkuthMalkuth Level 1
edited February 27 in ZenFone 8


I have had since I got the phone trouble to login to ZenTalk via the phone Setting - Support - ZenTalk.

I takes to the login page account . asus . com and when I put in my mail and password, the submitbutton are still "grey" unable to be pushed. I have password that is in the range of 8 to 25 character, and I have tried change the password with different amount of character, only alphabetic, only numbers, only symbols and of course back to mix of all of them. From 8 character up to 25 and not working.

I then try to login to account . asus . com via the web on the laptop (using the same browser as on the phone, chrome and also tried with Vivaldi) and it works, I can also accesss ZenTalk via the webbrowser on the computer.

I then opened my phone again, went to Zentalk via the settings -> support and still same trouble. I then tried MyAsus from the same Setting -> support -> MyAsus, and it worked perfekt.

After cleaning out the webdata, cashes and so forth on the phone, still it doesn't work. I have tested to allow all cookies, added asus page to whitelist to use javascript, and so forth. Still not working to login.

Anyone else that has come across same problem?



  • +1, I've had similar problems since I got the phone.

    Also, for me the entire forum was unusable during december - The page loaded, but then a grey transparent layer loaded on top and I couldn't do anything. I had to disable Javascript to browse the forum.

    I know it's because of the adblocker I'm using, but no way I'm turning it off.

  • Hi @Malkuth

    1. Could you confirm your current firmware
    2. Could you share a screenshot of the login message error that you get when trying to login?
This discussion has been closed.