Camera app stopped working after upgrading to Android 11

edited April 17 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: ZenFone 7
  2. Firmware Version: WW_30.41.69.143
  3. Build number: RKQ1.200710.
  4. Rooted or not: Not rooted
  5. Frequency of Occurrence: every time I run the camera app
  6. APP Name & APP Version (If your issue relates to the app): App Name: Camera; App Version:

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


I've been unable to run my phone's original camera app since upgrading from system update RKQ1.200710., on December 23rd 2021, to system update RKQ1.200710., on January 14th 2022.

Every time I try to run the camera app I get the error message "Camera is not ready. Please try again later".

I've tried running it in safe mode and I get the same error message.

I've tried clearing the camera app's storage and cache, and I still get the same error message.

The camera itself is working, though. I can use it on other apps like Instagram and Whatsapp, but the image is upside down and horizontally flipped, so making video calls is troublesome because My image is shown upside down to everyone in the call.

So something in the last system update messed up my camera settings and the phone's original camera app.

How can we try to solve this issue without running a factory reset on the phone? Because it will probably run into the same problem once it updates to version RKQ1.200710.

Thank you.


This discussion has been closed.