Pocket mode doesn't work?

GavinJSmart GavinJSmart Level 1
edited January 13 in ZenFone 8

Anyone else find this phone constantly turns back on in your pocket?

I'm constantly finding my phone has pocket dialed work colleagues, messed up my shopping lists, added junk to my calender etc when it's in my pocket after I've turned it off.

Sometimes I'll notice the phone has turned back on because it gets warm.

I've enabled pocket mode in settings but it's made no difference and the beta software hasn't helped either.

It's very worrying as anyone who stole this phone could unlock it by just putting it in their pocket for a few minutes.

I've never had this problem with an android phone before so I feel there's a massive security flaw in this firmware


  • Same problem here. My phone keeps ghost dialing and locks me out of my phone for 20sec while in my pocket. And this is with pocket mode ENABLED.

  • Hi @GavinJSmart

    Please try clearing cache files system-wide and then reboot your device:

    Settings -> Advanced -> Mobile manager -> Cleanup

    Also, please disable and enable pocket mode again.

    Let me know if the issue persists after rebooting your device.

  • Tried that, made no difference at all, still find my phone getting hot in my pocket and get it out to find it's been changing settings, posting crap on my shopping list widgets, opening apps etc..

  • It's got to a point where I miss important phone calls an emails now because I tend to leave my phone in another room because putting it in my pocket always results in things getting messed up.

    It's also a massive security risk because anyone could steal my phone and unlock it just by putting it in their pocket for a few mins :(

  • I have a very bad experience with pocket mode too. Sometimes the phone turns off wifi, sets silent mode, turns on the light in my pocket. The phone in my pocket became very hoot and the battery was empty.

  • I recognize the issues, but only in combination with face recognition for unlocking my phone. Mostly the shortcut buttons were accidentally activated or emergency numbers were dialed. So I went back to unlock only with fingerprints, and it now hardly occurs anymore.

  • Have you tried going to your security settings and tapping on unlock device. this opens up another window where you can try and turn off the settings there since I've had similar issues to this and this fixed for me.

  • I've turned off face unlock to see if that helps.

  • Check that you don't have tap to wake and swipe to unlock active. If you do, the screen will first turn on and then your pocket will "swipe" to unlock.

This discussion has been closed.