GPS not working right on Android 11

kpetrovkpetrov Level 1
edited November 12 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: Rog Phone 3
  2. Firmware Version: last two a11 versions
  3. Rooted or not: not
  4. Frequency of Occurrence: non stop
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Im using Maps everyday and I have a problem with location. It refreshes very, very slow and navigation is not usable.

I need to clear Google Play Services cache and storage every time I open Maps or other navigation app to work properly.

Comments

  • ronald1985ronald1985 127.0.0.1 Level 5

    Have you tried to uninstall updates and don't update the latest to see if it is better?

    Is it only Maps app that's the problem?

  • kpetrovkpetrov Level 1

    I tried 3 navigation programs and the results are the same. GPS updates very , very slow. After cleaning Google Play Services cache and storage they are working fine for a while and then same thing happaning.

  • I'm having this problem as well. A10 no such issues. Now the GPS seems like dropping very often. I can keep seeing that the "searching for GPS." It can locate my position but very slowly. When I'm on the move, it will update extremely slow till no update.

    What I had done and still not working.

    1. Clear cache and storage in Google map.

    2. Uninstall and reinstall Google map.

    3. Reinstall A11. Only overwrite, not factory reset.

    Now only left factory reset which I want to avoid at all cost.

    Apps use.

    Google Map, Waze.

  • ronald1985ronald1985 127.0.0.1 Level 5

    Go to Google Play Store and download GPS STatus Toolbox.

    Press on top left and then hit the menu. Press on Manage A-GPS State and press on Download. You will need to be connected to the internet though.

    Once done, go outside and start your maps app, it should hopefully start to use the satellites.

  • ronald1985ronald1985 127.0.0.1 Level 5

    In the same place, hit Reset and then Download. Then do the same. You need to allow time for it to download the necessary GPS data.

    Let me know how you get on after, though I don't have anything else to suggest.

  • s_lamerichss_lamerichs Level 1
    edited September 7

    This is a firmware issue, no third-party application or settings twiddling will fix it. You'll need to either wait for Asus to issue a patch (unlikely to happen any time soon, this issue was reported on the Android 11 update for ZenFone devices back in May and they still haven't resolved it), or roll back to Android 10.

  • Asus never fix their problems. 1 year ago I posted a problem with dual app viber that cant receive pictures and cant backup data. They closed the thread and never fixed the problem. I think here will be the same.

  • Just an update. I was trying to revert to A10 but didn't realized that it will factory reset. After then, it auto upgrade to A11 again.. zzz.

    Been using for a few days now. The Google Map GPS is working well.

  • Lets see what happened in few days after some updates (Google Maps or other google services) ...

  • Yeah. Had the same problem. You need to login into your wifi and then immediately deactivate wifi on your router or turn your router off. Because your phone won't load the update via mobile data.

    I have 1Gb/s downstream and after 3 sec the phone already loaded 380MB from 1,2 GB. 😅

  • kpetrovkpetrov Level 1

    Last couple of days maps working well for me. I dont know , but I think this bug is fixed. How about on your phones guys?

  • ASUS just released a new update where the problem should be fixed. I'm from Germany and reported the problem with many logs and videos and so on. And so they were able to get an update. But not tested the new update yet because I still have one issue not solved. I think A11 made the ROG Phone 3 slower while gaming. And it gets hotter. Still waiting for feedback from ASUS.


    Can someone test the GPS issue and give feedback here?

  • wayne.hbwwayne.hbw Level 1
    edited October 13

    Just to update. I did the Manual update to the latest release which supposed to fix the GPS. After updating, been using for 3 days now with GPS/Google map. It's working well. No issues.

This discussion has been closed.