Armory Crate not working after latest update

HeLLbOyHeLLbOy Level 1
edited October 29 in ROG Phone 5


  1. Model Name: ROG Phone 5
  2. Firmware Version: April
  3. Rooted or not: Not Rooted
  4. Frequency of Occurrence: Every time app is launched
  5. APP Name & APP Version (If your issue relates to the app): Armory Crate version 5.20.0.31_210813

After the latest update, the Armory Crate app doesn't work and launching it restarts the phone. I have reset the phone to factory defaults, as per support instructions, but the issue still remains.

Comments

  • I am facing the same issue. Whenever I try to open armory crate app the phone restarts.

  • Yes same issue. I also facing after last update.

  • Hi All,

    Can you share a video and mention the firmware version as well.

  • mangesh_singhmangesh_singh Level 1
    edited September 19

    i have faced the same issue and its consistent....cannot use armoury crate at all..as soon as the app is launched phone restarts...after so many users reported it still there is no update from asus or mere acknowledgement...u need ro do better ...the whole selling point were feature like armoury crate an it doesn't even work once now

    this is the firmware version...please reply

  • FunBike31FunBike31 Level 3
    edited September 19

    As this problem does not concern everyone, I am leaning towards a problem with the profile of a game.

    There will be 2 ways to test this, delete the profile of each game one by one (if Armory create is accessible)

    The second way is faster, if Armory create correctly stores the game profiles in the user's profile.

    - Remove your Google account from the phone

    The one that you use to play if you have several accounts (personal, pro)

    - Stop the phone and start it

    - go to Google profile and add your account.

    This is the only operation that allows you to leave with a user profile that has been corrupted and is less restrictive than resetting the phone from the factory. (no loss of data), in some games that use the profile, you will have to re-teach your date of birth if it was requested and possibly basic information stored locally.

    I forgot, if those who had this problem did a factory reset and still encounter the problem, then of course my solution is not good, but in this case I have no solution.

  • I did perform factory reset twice and unfortunately while resetting the device for the second time I forgot to backup my phone and all my personal photos videos documents etc are all gone.. and the issue still persists.

  • You may face WIFI/HOTSPOT off/on issue some days later..


    I am facing same issue with armory crate crashing just 10 days later Wifi issue starts, don't know they related or not??

  • Hello,

    After performing a factory reset and still this restart problem when launching Armory Create, have you tried to launch Armory Create before entering your Google account, you may have a different behavior depending on the order of operations.

    a) factory reset

    b) launch of armory create

    Reboot of rog5 Yes / No?

    c) Adding your Google account

    Reboot of rog5 Yes / No?

    If you have No in (B) and yes in (C), your Google account is the problem after you have synchronized data and settings.


    in this case, there may be a connection with this

    @ARP_ASUS

    The latest Firmware is now several months behind the Android security updates, they are now all known and this is becoming critical, it is added that of the main application of Asus present on all Rog !!!, regardless of the Bug fixes, it would be desirable to have at least August and September urgently as well as a revision of Armory Create.

This discussion has been closed.