The network usage display in the status bar randomly stops working and shows a dot

eddddedddd Level 2
edited October 2021 in ZenFone 7 Series
  1. Model Name: Zenfone 7 Pro
  2. Firmware Version: WW_30.41.69.89
  3. Rooted or not: No
  4. Frequency of Occurrence: Always roughly 1-4 Weeks after every phone restart or Wifi toggle
  5. APP Name & APP Version (If your issue relates to the app):

========================================

This issue has been present ever since I enabled the current network usage / speed display in the status bar. At some point in time it stops working for Wifi and only shows a dot. To get it working I have to either disable & enable Wifi or restart the phone.

If the Wifi gets out of range or is disabled, it starts working. As soon as I get into Wifi, it stops working. Only tested on home Wifi so far.

Comments

  • eddddedddd Level 2
    edited September 2021

    I restarted the phone today and the usage still shows a dot, unless I pull down the quick access menu from the top. Then it shows the current network speed but only as long as the menu is pulled down. Is this a feature? It is quite confusing in my opinion. If I enable the network speed, then it should just display it all the time... Interestingly, I remember it working all the time before last update. Any ideas?

  • wasn't it because your status bar was "full"?? try to get rid of one or two symbols at the time when that happens to see if the network speed is back or not (disable alarm, turn off BT etc)

  • There is tons of space there. Even then, why is it displayed when there's even less space when pulling the status bar down?

  • Yesterday it started working again out of the blue. So, no, the status bar has plenty of space. All that changed is that I went on a road trip the day before and was turning the hotspot on and off multiple times I guess. I did not notice the phone restarting (it would require a PIN if it did).

  • The dot is shown if there is too much icons in the status bar, even if to you it's not "full", after a certain number of icons, it will show a dot.

    Hotspot adds an icon, it may be one too much.

    Do you have another icon that was not there before ? Like the camera flip lock one, or two sim cards ? Phone in vibrate mode only ?

    Just remove icons you don't need and the network usage will always be shown, that's what I did.

  • eddddedddd Level 2
    edited September 2021

    You're right, it was the vibrate-only mode making the status bar overflow. So this dot is a general Android thing when it's full? They could've used three dots so people actually understand...

This discussion has been closed.