Notification LED stopped working

BPMBPM Level 3
edited October 2021 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: ROG Phone 3 ASUS_I003D
  2. Firmware Version: 18.0410.2106.138
  3. Rooted or not: no
  4. Frequency of Occurrence: constant
  5. APP Name & APP Version: any/all


Alright, so the notification LED seems to have stopped working today for ALL incoming notifications. The LED still works when recharging the phone, but not for notifications. It's not blinking for Gmail, Google Messages, games, smart home apps, etc.

I'm fairly certain it was working just fine yesterday, too. Just started having issues today. There doesn't appear to be an SMMI test for the notification LED so I can't test to see if it's a hardware issue.

I've gone into the settings (Display ➡️ Light management ➡️ LED indicator), made sure the option was enabled. Disabled it, enabled it, no change. Rebooted the device a couple of times, no change.

Tried checking previous threads about this, seems this has been a common issue across multiple ASUS phones (both ROG and Zen), with no clear solution.

It's not a major issue to me. I've had several phones that did away with the notification LED completely, but it is a nice feature to have... And if you have it, it would be great for it to be working, ya know?



  • BPMBPM Level 3

    Update: since posting this, the notification LED has worked... sometimes... but not always.

    Now, another issue I'm running into is with some notifications not popping up until after I've opened the app. A couple of examples:

    1) I play Pokémon Masters EX, and it'll give a notification when Pokémon eggs are about to hatch... except I'm not always getting those notifications until after I've already opened the game. Not a huge deal, but annoying.

    2) I use the Google clock app instead of the ASUS clock app. I use the timer to time my breaks during work. Since last week, I've been having an issue with getting those notifications. The timer alarm doesn't go off until after I bring up the clock app. This is a big issue for me.

    So yeah, some help with these notification issues would be great.

  • i did notice this as well a couple of months back, it doesnt bother me so I didnt report it but the LED inconsistency has been a thing since a very very very long time.

  • BPMBPM Level 3

    Oh? Weird. I never noticed any issues until now. Guess I was just lucky.

  • Pretty sure its due to android being android. I don't think it's a bug from ASUS's LED system but android's battery optimization system. Go into settings -> apps -> special priviledges-> battery optimizations (not sure if it says that I'm translating from danish here) find the app you want to display notifications at all times and set it to "not optmized" I believe that will fix your LED problem.

  • BPMBPM Level 3

    Still having issues with this...

    I set a timer in the Clock app, and it didn't go off. In this case, the notification is still there, and it showed it was 2 minutes past the set interval, but it didn't go off until AFTER I switch to the Clock app.

    I've gone into the app info, made sure battery optimization is disabled, all permissions are enabled, and just about all notification options are enabled... And yet the timer alarm still doesn't go off.

    I've even cleared the cache/data and reinstalled the app. Nothing.

    @Gustav_ASUS, @Irene2_ASUS, or anyone else... Any ideas?

  • Similar problem with Notifications' RGB back LED Aura lighting and sounds here

    It hasn't been fixed, and by reading issues with A11 I'm reluctant to upgrade to it, especially for the proximity sensor issue, among others.


  • A11 is not having a single bug or atleast me and some of the users i am in contact with and for the proximity bug , its been fixed with latest .158 update with latest security patch and new dynamic themes , which i personally loved it

  • BPMBPM Level 3

    Alright, so it happened again, and this time I took some screenshots to help illustrate the situation.

    In the above screenshot, you'll see the Clock notification is there, and that the timer is now over 4 minutes past when it should've gone off, but didn't.

    Only after I launch the Clock app does the timer alarm finally go off.

    This only happens sometimes and not always. I hate to say it, but this never happened prior to upgrading to Android 11 (and I am currently on the most recent update).

    I've checked permissions, I've checked notification settings. Not really sure what else I can do here to fix this...

  • Feel free to upgrade, the latest A11 is 100% bug free, proximity bug and syncing bug has been fixed and everything is fully functional now.

    @BPM have to ask, but did you to a factory reset? Also for me lately the notification works now since I found the cause for my particular problem. As you already noted, this isnt exacly uncommon for any phone to have buggy noticifaction LED, since it's typically android related with their battery optimization stuff. I assume your issue right now is caused by something that triggers some sort of battery saving mode when it does off.

  • BPMBPM Level 3

    Negative. Haven't done a factory reset since I really haven't had any issues until this started happening. Would kinda hate to do so, since it's such a hassle to have to set things back up again, heh...

    Was kinda hoping there'd be another solution before I have to resort to the nuclear option. 🙃 Though, I'll keep it in mind.

  • I mean the LED thing is more than likely an android thing, so u'd have to ask in bigger forums such as samsung, maybe some people there who invested more time into it can tell you why android wants to be a special snowflake at times.

  • Thanks for the feedback, I will give it a try

  • I've updated to 18.0410.2108.158 (with factory reset) and I'm experiencing the same problem with both notification LED and RGB back LED Aura lightings. I'd say it's intermittent in any case.

    Sound and vibrate notifications are fine, it's just the lighting that doesn't work properly. I've tested further and it for SMS app LED doesn't work and the Aura light works, for other applications is the other way around. Sometimes when it works, it does for both in some applications. Of course I made sure that all battery optimisations, hibernation, etc etc etc are fine for the offending apps.

    So 🤷‍♂️

  • To be clear: my issue is less about the notification LED. I don't care that much about it. My main issue is just getting notifications, period (as first noted in my comment on August 15, and further detailed on August 31). I kinda feel like this is getting ignored and overlooked... almost a month since I've created this thread, and not a single response from a forum mod...

  • It's an android thing. As I said, the LED and notification thing isnt uncommon on other phones either. This is why I said look into samsung forums as they are the largest, maybe look through android subreddits. I'm not sure how mods are supposed to help as it's a widespread weirdness from android as an OS.

  • Ah, gotcha. I thought that was just about the LED thing.

  • Well it still is, both are linked. The reason the LED isnt going off is because android isnt aware of any notification. The moment you press the powerbutton it checks and realizes "Oh hey, there is a notification". Once you solve the notification on sleep, you fixed your notification LED as well.

This discussion has been closed.