Unable to send MMS on mobile data

LuchulainnLuchulainn Level 1
edited September 2021 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: ROG Phone 5
  2. Firmware Version: 5.4.61
  3. Rooted or not: Not
  4. Frequency of Occurrence: Always
  5. APP Name & APP Version (If your issue relates to the app): default messaging app

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


I bought an ROG Phone 5 a week or so ago switching from my iPhone X. Since then, I have been plagued with issues but none so frustrating as the inability to send MMS when not on WiFi.

I am in Australia with Optus. I have had call after call with Optus trying to resolve the issue and they say it is my device and not their settings and I believe them, since I did not have this issue until swapping phone.

I've tried all the troubleshooting I could with Optus and on my own and nothing worked.

Whats the go? Can we get this looked at?


  • Sorry here is my versioning info. Don't think I entered the correct firmware info.

  • Join the club. The big problem here is ownership,as in is it a Google bug or an Asus bug ????

    Many different phones including my wife's Nokia g 10 have this problem so I think it's a Google bug!

    I should have said that my wife's Nokia g 10,,had this problem,, until I found a Google page on the correct settings for MMS. Now I found a few different APN settings pages on Google but only one of them worked. If you go down this path make sure you input the settings exactly how they come up as a simple commer or dot out of place will haunt you and not work.

    Good luck and don't stress, you will work it out

    PS I am with ALDI prepaid which uses the same network eg Telstra mobile network so if I could get my wife's Nokia g 10 to work you should be able to get the ROG 5 to work

  • Nothing on this? I've seen lots of posts related to it and clearly Roystoys is affected.

    Even if it's a Google thing and not an ROG thing, shouldn't someone know what's going on?

  • Strange thing is if I have wifi and mobile data on and am at home connected to my router ( Asus RT ac 88 U) it will,, sometimes,, not send MMS,s but if I turn WiFi off it will work with mobile data

    It's a very perplexing bug and as I have stated,we need to find out who owns the bug eg Asus Google or Telstra????? If we can work that out we can bombard them with bug reports and complaints until they fix it!

This discussion has been closed.