Screen flicker still occurs while using Chrome

GabeGabe Level 1
edited September 18 in ROG Phone 2

Using ROG Phone 2 8gb/128 (ASUS_I001DD)

Firmware 17.0240.2105.90 (non rooted, all original)

Chrome 91.0.4472.120

Always happens when there's a small video window running while scrolling through a website (normally those video ads).

The entire screen flickers a little depending on the colors shown on the website and on the video, like if the device seem to be trying to auto calibrate the screen to the right setting but just can't and keep trying, changing between different screen contrast and maybe other auto settings.

It's not a new problem. Plagues my device since I bought it (last year), but the latest update said this would be fixed while using 120hz and so far it's not.

The "Splendid" video calibration is set to "cinematic". I can't say for sure, but seems to be linked to this splendid thing.

Thanks in advance and I hope Asus can take a look into it.

Comments

  • I assume it's more of an issue with switching the HZ. Try to run the screen at 60hz, if it stops the flickering then it's defnitely caused by the phone switching the frequency back and forth.

  • GabeGabe Level 1

    Does it switch the frequency when I set it at 120hz (I don't keep changing it... Always use at 120)? The smoothness of the scrolling in the screen doesn't seem to indicate that it step down to 60.

  • This is why I asked you to try it. The flickering probably happens because when videos are playing it switches to 60hz.

  • My main browser is Opera and flicker problem doesn’t happen while I am using Opera. But still, sometimes when I use google feed and enter any website through google feed if there is any video my screen starts to flicker. It’s really an annoying problem.

    Btw, I always use my phone on 90hz.

  • ronald1985ronald1985 127.0.0.1 Level 5

    The last time when this was reported was using YouTube website (not the app). I have tried other websites which has video ads to them, but the issues doesn't seem to appear.

    Do you have a website which the video shows this is happening?

  • MajQMajQ Level 1

    Turn off "Android SurfaceControl".

    Go to chrome://flags and disable it.

  • GabeGabe Level 1

    Finally found one link that wasn't an ad causing the flicker, so it should be replicable by anyone (as ads are region dependant).

    Here:

    ...yeah...sure...the forum won't allow me to post links cause I don't have that many posts yet... So, just add the HTTP and www before the link below

    pcgamer.com/I-need-these-gorgeous-IRL-Minecraft-blocks/

    In fact at 60hz the flicker doesn't occur, but it does at 90 and 120Hz.

    Gonna try MajQ work-around.

  • GabeGabe Level 1

    You just nailed it, MajQ! It really fixes the problem! After a year it's finally fixed! Thanks a lot!!!

This discussion has been closed.