Armoury Crate Service ERROR

amirarsalanamirarsalan Level 1
edited July 2021 in Others
  1. System: windows 10 64 bit
  2. Battery or AC:
  3. Model: ROG STRIX G531GT
  4. Frequency of occurrence: frequently
  5. Reset OS:
  6. Screenshot or video:


Detailed description:Hi , Recently i had some Armoury crate problems which i couldn't do anything in armoury crate since it didn't recognize my device and gave me a service error , i came here saw some people having the same problem and done what they've done but it didn't help , so i reinstalled windows and installed all drivers and when i wanted to install armoury crate it gave the same problems . i deleted and installed it again , i checked services and other stuff but i didn't find any thing that can be a help , i have a G531GT which mostly people with this model have the same issue , my laptop gets overheating since i can't set it to turbo and by default its set on windows mode , Pleasee Pleasee Please help this service error thing is makin me crazy ,




  • Hi there,

    May I have a screenshot of the error code?

    Thank you.

  • Hi There @Blake_ASUS , Here

  • Hi there,

    Please use the uninstall tool from below link to uninstall Armoury Crate.

    Then use Geek Uninstaller to check if there is any Armoury Crate related app/driver is still in the device.

    You can share the screenshot and we can check it together.

    Then also use the installer in the previous link to install armoury crate back.

    Thank you.

  • RickyTsukiRickyTsuki Level 1
    edited June 2021

    Hello, I have the same problem and tried this process, but after reinstalling I still have the same Service Error. Is there a way I could manually uninstall all files so I can have a 100% clean install of Aromury crate?

    EDIT: I forgot to add my PC info.

    I also have Windows 10 64-bit and my laptop model is ASUS TUF F15 FX506LI, the error happens every time I open Armoury Crate

  • @Blake_ASUS Hi there , i just uninstalled armoury crate using the link that you gave me , and i checked that if there is any armoury crate related app/driver on my device using Geek Uninstaller Just as u said , now im gonna restart my Pc again and try installing armoury crate from the same link , I Hope it works , i'll notify you when its Done


  • amirarsalanamirarsalan Level 1
    edited June 2021

    Hi There @Blake_ASUS , i tried installing armoury crate for the past days , and every time i get this error though my internet is alright and has no Problems , I would Be happy if i get your opinion on This


  • Would you mind to share the whole program list?

    Because Amroury Crate related drivers might not be named under "armoury crate".

    Thank you.

This discussion has been closed.