A11 major problems with Gmail notifications

12357

Comments

  • and I found out again that I am not receiving notifications so another reboot...

  • RoystoysRoystoys Level 4
    edited June 7

    Welcome to zenfones !

    They are a love/ hate relationship 💘

    But let's face it, aren't all phones ??

  • just to let you know how frustrating it really is...I had to reboot the device again as I found out that for some time I wasn't getting the notifications

  • it seems that notifications from affected apps work only like 30mins or so after I reboot and then it stops working :( I'll do another reboot even though I've just rebooted the device...it's gonna be maybe 6th reboot today

  • skipwoofskipwoof Level 1

    I received OTA update, but no fix at all for notifications. So I moved to OmniRom, and no more issues on my side :

    https://forum.xda-developers.com/t/rom-official-omnirom-for-zenfone7-7pro-android-11.4203251

    I will maybe revert back to Asus ROM once they fixed all this stuff. If they fix it one day.

  • kr0mkakr0mka Level 2

    I'm also having issues with notifications since a couple of days, Gmail is completely silent as well as the weather app, the clock widget is showing the warning symbol instead of weather and I have to open the weather app manually in order to get the widget refreshed.

  • Same issues for me, I don't get any Gmail notifications unless I restart the phone every couple of days.

    Same for the weather widget not updating by itself in background.

    Many apps have delayed notifications when it happens, it's irritating having to wake the phone up to check for notifications, that's not how notifications should work, it should notify you, not you having to check if there's delayed notifications.

    If this issue is tied to a background service, maybe add a setting to auto-restart the phone at night like Samsung does.

  • I've sent you two a PM with log instructions. Maybe your logs can tell us more than the ones we already have. I hope we can see a pattern with your help

  • nidhin3nidhin3 Level 3

    Notification issues are a common thing now irrespective of brands I guess... I've seen similar reports from OnePlus 9 series & Nord users ( not sure if other models/ devices from other OEM's too are affected)

    Even Apple users are seen reporting various notification issues...

  • It's not just a notification issue, many native Google and Asus apps are just not updating in the background.

    The Play Store never checks for update, Gmail never sync emails, Weather never update the weather. All of this only update when you launch each app, despite being allowed to run in the background.

  • Let's say that the notifications for gmail, maybe, just maybe, are for other brands too...I don't really deny it, I know some other brands have also some issues. But how can you explain that if I leave the phone untouched for a lot of hours nothing notifies me....no app, nothing. How can you explain the fact that the weather app does not update by itself?

    I have to go through each app that I use just to check the notifications.

    This happened to me on a very old xiaomi phone until I disabled the battery optimization. Since that point on it worked fine. With ZF7 even disabling battery optimization does not work anymore....so I just have en expensive brick, that acts as a phone (at least so far it rings...) And other than this I have to check everything manually...nice phone...what could I say...

  • nidhin3nidhin3 Level 3

    Ohh I thought the issue was mainly with the Gmail app as most users were seen talking about that only...

    So this issue is happening with Google apps + Asus apps ? Are all third party apps too affected ?

    Anyways, from what you told this looks like a nasty issue... Hope the concerned devs can bring a fix soon...

  • Initially I have observed this only for gmail and calendar app. But because it affected me quite a lot, since I rely on notifications, I started to check for a workaround and other stuff, and then I noticed that a lot of apps do not send notifications. Not only gmail, but most of them... (The only unaffected apps are the messaging apps, though at some point telegram failed to notify as well). And then I checked further and I noticed that the apps are being killed (or at least are not working) and never resumed and that's why I was not getting notifications. So in my opinion something from A11 kills the apps(most probably to save battery) and the code that was supposed to start them is not working, since them are not started anymore unless I go to that app.

    At least this is what I observed on my mobile. And I could not find a workaround for it. I have disabled all optimizations and it works well for some days...but then at some point it starts to fail...and I have no idea why or what I could do....

  • Yes, only some native Google and Asus apps, but not all, for example YouTube never fail to notify me.

    Other apps are fine, I can get notifications and background updates from Outlook, Whatsapp, Twitter, Instagram, Skype, Pokémon Go, ...

    Only some Google and Asus apps never update in the background and I have to open it manually so it gets up to date (I can see the last weather update being far in the past, or emails arriving only when I open Gmail).

    I did record a log and send it to Asus, I hope it will help them find the issue.

    I left Samsung because of similar issues and a dying battery, I was pleased with Asus until a few weeks/months ago since this happened... Where will I go next ?

  • I didn't know they have a safe mode. But as far I read it seems like the system is right after factory reset...I will try it just to check...but I reset the phone at least 5 times after A11 update and the result was always the same. After a while I loose notifications ... Lately is even worse, neither reboot helps much....

  • To enter safe mode

    1. Press and hold the power button until power options appear.
    2. Tap and hold the on screen Power Off button.
    3. Hold until you see Reboot to safe mode and then tap on the prompt.

    Once you're in safe mode, make sure your phone is connected and send yourself an email from another device.

  • nidhin3nidhin3 Level 3

    Yeah, just try once mate... Can see if it's a third party app that is triggering the issue...

  • Finished trying...same thing as well in safe mode....

    As I said before before I opened this thread I tried everything: factory reset once direct after update...then noticed something wrong with the splendid app and I did another one. After that I loaded all my apps again and let it run...after a couple of days once I lost some emails I started to notice the notifications issue. So I did another factory reset. Then downgraded to A10 and let it run for a couple of days and all was fine. Updated again to 11, factory reset again after upgrade, load apps and since then the story with the thread...so after multiple factory reset, the issue is still there...

    On A10 with the same apps and usage all works fine. With A11 for a while, with all battery optimizations off, the notifications are coming...after a while it stops...and I see that the apps are not refreshing ..them are killed and never restarted...so you have to go through all your apps to start them again....but at some point them stop again...and I loose again notifications ... Reboot helps for a while but not always ...

  • nidhin3nidhin3 Level 3

    Okay mate... Well, if I were in the same situation, the next thing I might try is to disable system and pre-installed google apps ( won't disable the ones that are critical for the functioning of the device) one by one just to check if someone is the culprit... Also, I will try to uninstall the updates if possible... But I guess thats a lot of work...

    BTW, did the latest update (WW_30.41.69.78) bring any improvements ?

This discussion has been closed.