FN+Arrow Keys no longer change aura brightness of the keyboard_ Brand New Asus TUF A15 FA506QM

rnogueira611rnogueira611 Level 1
edited February 9 in Others
  1. System: Windows 10 Pro 64bits
  2. Battery or AC: Both
  3. Model: Asus TUF A15 FA506QM (R7 5800H + RTX 3060 + 16gb 3200mhz)
  4. Frequency of occurrence: Always happening, since a few days ago
  5. Reset OS: Not yet
  6. Screenshot or video: -


Detailed description:Every Hotkey works perfectly, including the FN+RIGHT/LEFT hotkey to change the aura mode, but the FN+UP/DOWN stopped working a few days, I haven't done anything in particular to cause this problem, the pc is brand new, i got it 10 days ago, it is pretty much stock.

Help please.

Also, when I run diagnostics on MyAsus app, it doesn't let me see the result for some reason.



  • Hi there,

    The arrow up and down should be working for keyboard backlight.

    So you mean that the backlight no longer lights up? or the backlight can not be adjusted anymore?

    Thank you.

  • DiskunDiskun Level 1

    I have the exact same issue on the very similar ASUS TUF A15 2021 FA506QR (R7 5800H + RTX 3070 + 16gb 3200mhz).

    Until a few days ago everything was fine. Now FN + Arrow Left/Right (<Aura / Aura>) changes lighting mode but FN+Arrow Up/Down won't change keyboard backlight level. Also I'm not getting an on-screen prompt for FN+Up/Down anymore.

    Keyboard backlight can be set on Armoury Crate app, but not by using the keyboard shortcut. Not even on the BIOS screen, which means something must be broken at a firmware level.

    This used to work until a couple days ago. I don't recall getting any updates recently that could have triggered this. I have tried everything, even formatting the system and reinstalling Windows from scratch which I just finished doing. It proved to be a waste of time.

    This is really inconvenient and makes me wonder why a feature such as keyboard backlight depends on unreliable software from ASUS. My old laptop didn't require any software for basic keyboard lighting control.

  • Hello Diskun,

    May you check in Windows update history or Armoury Crate live update page to see if there was any recent update of the firmware?

    Please reinstall ASUS System Control Interface V2 driver and see if it helps.

    Thank you.

  • DiskunDiskun Level 1

    Hi Blake,

    I have attached a video of the issue.

    I'm on the latest firmware (406). Downgrading to 405 didn't change the keyboard behavior. These are the only two available.

    I also tried reinstalling the Asus SysConInt V2 driver, keyboard behavior still the same.

    I'm a L3 SysAdmin and worked in support so I'm familiar with troubleshooting procedures. This is what I've tried so far, testing the keyboard hotkeys on each step:

    • Unplugged all peripherals.
    • BIOS set to default values.
    • Full Windows reinstallation (fresh, all partitions removed prior, like factory)
    • Tried with no drivers.
    • Tried with the Windows Update automatically provided drivers.
    • Tried with the latest drivers and firmware from the support page.
    • Applied firmware hotfix from the above URL (Version V005 - 2021/02/02 130.23 KBytes - PD Firmware - Applicable to BIOS 400 or above version) What does this even do by the way?
    • Installed MyAsus and Armoury Crate, applied available updates.
    • Tried reinstalling the SysControlInterface V2 driver V3.0.4.0 (latest).
    • Tried downgrading to SysControlInterface V2 driver V3.0.2.0 in case the latest version caused any issues.

    None of these solved the issue. No other software or drivers apart from the essentials were installed for these tests.

    Prior to this issue I was using my laptop for a mix of work (MS Office, Teams, Citrix apps, Powershell coding, etc) and gaming (Cyberpunk 2077, Apex Legends). Then suddenly two days ago I lost the ability to change my backlight intensity unless I do it by hand on Armoury Crate.

    Since I already performed a system reset I'm unable to check whether I got a firmware update that caused this in the past. However the issue persists even in BIOS (previous to this I was able to control the keyboard backlight at any time) so it must be some firmware patch related to the keyboard lighting hotkeys.

    Also it seems I'm not the only affected user so the update must have been automatically applied either as a Windows Update or a MyAsus/ArmouryCrate.

  • I have EXACTLY the same issue...

    Tried more or less the same things and nothing so far.

    Is there any solution out there?

  • Hello Diskun,

    May you try the latest ASUS System Control Interface v3 V3.0.5.0?

    If it still does not work, please kindly send the device to our service center.

    Really sorry for the inconvenience caused.

    Thank you.

  • DiskunDiskun Level 1

    Hi Blake,

    I'm afraid that didn't help. However I'm not sending my three weeks old laptop for service since I'm currently on the move and I already discarded my old device. I refuse to send an entire laptop to service due to a software-caused issue, and thus, I'd like a software-based solution that doesn't involve a long turnaround time. Unless it can be replaced on-site, of course.

    Moreover, replacing the laptop probably won't guarantee I won't get the same issue again due to a firmware update.

    Could you please try and contact someone in ASUS who is familiar with the keyboard firmware?

    I'm willing to assist you in troubleshooting this as much as you want, but replacing an entire machine just because of a keyboard firmware issue sounds unreasonable to me.

  • DiskunDiskun Level 1

    ps. Proof of the driver update. Of course I rebooted my PC after.

  • If anyone founds a solution please post it here, I really cannot stay without my pc because of online work...


    I've upgraded everything, including ASUS System Control Interface v3 V3.0.5.0, still nothing.

  • edited May 2021

    Hello Diskun,

    Well... you have done everything for the software part...

    and the firmware 406 you mention is BIOS, not keyboard firmware.

    So it would be very helpful if we can find out what has been updated or modified before the issue occurred.

    But anyway, I will double check with our technical support.

    Is the OS on your device from factory? or you have installed your own before?

    Thank you.

  • Hi rnogueira611,

    Would you send the device to our service center instead?

    Please share your product SN and the RMA number in the PM I send you.

    Thank you.

  • DiskunDiskun Level 1
    edited May 2021

    Hi Blake.

    The system came from factory with no OS from an authorised, reputable reseller. I installed the OS myself both the first time and after the incident started happening, using the same Windows 10 20H2 USB drive (created with the official Windows Media Creation Tool).

    Thank you for your assistance btw.

  • Same here, right now I'm on 21H1, but this problem appeared when I was in 20H2.

  • So both of you bought the non-OS device?

    Hello Diskun,

    I would need your product SN as well.

    Please share it in the PM I send you.

    Thank you very much.

  • DiskunDiskun Level 1

    Serial Sent via PM.

  • Hello everyone, my bios version is 305, but in asus support page it doesn't appear anymore, I'm guessing that was the update that cause this problem, is it possible to go back to ver 304?

    And yes, I bought the pc with no OS installed on it.

    Best regards

  • You may use easy flash to downgrade BIOS.

    Thank you.

  • Hello everyone, can you acess the bios ver304 file?



    It says "Not found 404", help please :))

  • DiskunDiskun Level 1
    edited May 2021

    You are right, apparently they have removed the BIOS section from the Support downloads for both FA506QM and QR. There is only utilities now. PD Firmware Hotfix V005 for the QR still shows in the list tho.

    It looks like Asus screwed up badly with the BIOS updates and thus decided to remove them altogether. Let's hope we get a fix soon 😕

    edit: I found that at least they kept BIOS v406 for the FA506QR apparently, but it's hidden:


    The others are missing from both the support page and URLs.

    Please see above, Blake. We'd like a little bit of transparency at this point, please. And access to previous BIOS versions if possible. Thanks.

This discussion has been closed.