Asus Zenfone Maxpro M1 not charging

rose_vendettarose_vendetta Level 1
edited March 2021 in ZenFone Max Pro Series

Please tell us some basic information before asking for help:

  1. Model Name:
  2. Firmware Version:
  3. Rooted or not:
  4. Frequency of Occurrence:
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


  1. Model: Asus Zenfone Max Pro M1
  2. Firmware version: Not sure since it died out.
  3. Rooted or not: Not Rooted
  4. Frequency of Occurrence: It just happened a several hours ago.
  5. App name and App Version: Not sure

My phone was on 50 percent when I left it for like 5 hours. Suddenly, when I came back, the battery was already dried up. I tried charging it but to no avail. The only thing that pops up is the red LED light, then it's immediately replaced by flashing lights coming from the screen. The phone's been charging for almost 12 hours now, and it's still dead. I tried all of the troubleshooting protocols, even buying a new cord and charger but it's still dead. I also tried the power button troubleshooting but it's still dead. It just keeps on flashing lights from the screen, but there are no obvious changes ever since.


This discussion has been closed.