luongdv3luongdv3 Level 1
edited February 2021 in Others
  1. System: Windows 10 Home
  2. Battery or AC: Both
  3. Model: Zephyrus M GU502GV
  4. Frequency of occurrence: always
  5. Reset OS: Yes
  6. Screenshot or video: No


Detailed description:

I have been using Asus Zephyrus M GU502GV. Yesterday i just bought a WD Blue SN550 M.2 SSD NVMe 500GB.

After this SDD is installed in slot M.2, then I power on this laptop, but stuck on the Asus logo screen. none of the F1-F12-DEL-ESC keys work. except the power button to turn off the laptop. (sv nvme must be removed for my laptop to boot).

After that incident, I did a search on the internet, and found quite a number of cases happened to other people. they have updated the bios, settings related to m.2 / nvme in the bios, but it didn't solve the problem. so they must to remove SSD or replace the SSD with specific brand / type to make their tuf laptop could boot again.

Things I have tried:

Pulled out my Intel 660P and just plug the WD SN550, the boot process stuck at Asus logo, no BIOS.

Put back my Intel 660P and pull out the WD SN550 the system is boot normally again.

Update to the latest BIOS (ver 309), still no luck.

Enter BIOS, disable Fastboot, Secure Boot etc and then plug back the WD SN550, still no luck.


Question: what causes this to happen? what ways can be done to fix this problem?

Thank you very much in advance for the answers and support!🙏


This discussion has been closed.