Zenfone 5 ZE620KL - Bricked -> No USB-debugging, No recovery, No ROM, No unlocked bootloader, No ADB

qotsa73qotsa73 Level 1
edited February 2021 in ZenFone 5 Series


I don’t know how I got into this mess. Here is the situation:

All I have access to is “fastboot mode”. I can see serial number from powershell when I use command “fastboot devices”.

I do not have access to:

  • Recovery (stock or custom)
  • ADB
  • Developer options or any OS (to enable USB-debugging, it is disabled)
  • An unlocked bootloader. (tried to unlock it but failed, I guess it requires the unlocking app or adb access (which requires enabled USB-debugging)

When I try to boot recovery.img or anything else with fastboot commands on powershell, it fails.

I can provide you with any further information if needed. Can someone help me out? I just want my phone back, I promise I won’t mess with it again😅

Thanks in advance...


  • Have you tired to flash signed boot and recovery img with fastboot?

  • qotsa73qotsa73 Level 1
    edited August 2020


    I’m a noob when it comes to these topics, but when browsing through internet to find solutions, I saw that signed imgs actually can work in a situation like that

    I have not tried flashing signed imgs, I couldnt find those files, could you help me with finding them?

    All I’m looking for is having a phone with stock rom and stock recovery (if better TWRP or CWM would be ok too) back again, so related versions of those files (or at least guidance for where to find them) (and if possible a brief decription of what I should do with them (I know the basics) step by step ) would be great...

    Thank you so much, waiting for your answer though. Have a good day...

  • Which firmware version were you using?

    If you send me your email address I can send you those signed images.

    Or I can explain how to get them, but it takes a little time if you've never done it before.

  • qotsa73qotsa73 Level 1
    edited August 2020


    I couldnt figure out how to send private message, so here is the e-mail address.

    I dont know what the firmware exactly was, but I was using WW (from europe) Android 10 when phone got into a bootloop, and then when I tried to save it, everything got messed up, the ROM and the recovery got deleted, so I need both now.

    I have been using the WW Android 9 Pie for a long while with all the latest updates, and then I downloaded the stock ROM for Android 10 from the Asus website and upgraded the phone.

    So, if you think its stable, and its ok to use Android 10, its ok with me as well, otherwise you can pick the most suitable one. As for the recovery, you can also pick the suitable one.

    Hope I could provide enough information about the situtation, let me know if you need more. Thanks again. Awaiting your reply...

  • Lol, I thought the message I have typed was not sent, so I furiously re-typed it and here it is now 😂

  • RickkkRickkk Level 1
    edited August 2020

    Thanks for both messages :-)

    I've sent you an email, you might want to edit and remove your address from here now so you don't get added to loads of junk mail lists.

    I've not been able to use my phone either on Android Pie or 10, as I can't unlock the bootloader and root it, so sadly I can't comment on performance. Although my old trusted HTC runs smoother on Android 10, so I would hope this is the case with Asus.

  • Hi Rickkk

    I just deleted qotsa73's email address and the double submit message. Besides, qotsa73, are you not able to access the Recovery Mode? Please try the following steps to access recovery mode for the Factory Reset:

    0. Try to back up your data with USB cable

    1. Power off the phone, then keep pressing "volume down key"

    2. Press "power key" and stop press " power key" once you feel the vibration. Still keep pressing "volume down key".

    3. Stop press "volume down key" once you enter [Android Recovery] Screen

    4. Choose "Wipe data/factory reset">"Yes"

    5. "Reboot system now"

    #Hardware Reset Guide


    Please note that once the steps are completed, all data, apps, settings and personal information will be deleted.

    Furthermore, as Rick said, the unlock tool issue is now under investigation. Kindly refer to the link below for the latest information.

  • RovicRovic Level 1


    Can i also request for signed boot and recovery file? since my phone got the same issue

  • Since you have already in fast boot mode through powershell in PC, type this command "fastboot reboot recovery" without "" to enter recovery mode.

  • Algué me ajuda ?? Estou com o mesmo problema

  • Im having the same issue icant flash firmware because i have locked boot loader. I cant go to recovery mode also. I can only go to fastboot mode. Somebody help me please. [email protected]

  • I had this same problem when i flash my asus ze620kl please help me this is my email [email protected]

  • Ömer FarukÖmer Faruk Level 1
    edited October 2020

    Good day sorry for my bad English ...

    I have the same problem, please can you help me?

    E-mail: [email protected]

  • Hi friends

    Thank you all for your asking. If you haven't unlocked or rooted your device, please try the steps I mentioned above to access recovery mode for the Factory Reset. If the situation remains the same, according to what you described, please contact ASUS repair center in the country of your residence: https://www.asus.com/support/Service-Center-All-Countries/

    If it is impossible to access the service center during Covid-19 period, please try Call us: https://www.asus.com/support/CallUs

  • Same problems =口=

    Could you help me?

    E-mail: [email protected]

  • Selamun Aleykum , sorry for my bad english. For Zenfone 5 that stays in fastboot mode and won't turn on, you should try it. I have the same problem solved. Have a nice day. Link: https://solusizenfone52018.blogspot.com/2020/06/solusi-zenfone-5-ze620kl-stuck-di.html?m=1

  • Hey, I'm stuck in the same situation as @qotsa73 and I am in desperate need of those signed boot and recovery files and how to get them. Please help me out thanks!

  • MegyKMegyK Level 1
    edited January 2021

    Hello, my Zenfone 5Z got bricked after an official update via OTA to android 10, since then I've never been able to power it on, access to fastboot or even connect it to laptop.

    Since it's not on warranty anymore I've opened it and tried to disconnect the battery (that worked to my old Zenfone 2, before it died for no reason) and I've also checked the power button coz it was hard sometimes, but it seems to be ok.

    When i plug the USB to the charger it still get all warm, so I assume there's power, but still no life..nothing show on the display

    Any idea on how to unbrick it?

    Will an EDL USB cable work?


    I managed how to go into EDL and now my laptop sees it as "Qualcomm HS-USB QDloader 9008 (COM3)" but i cannot do anything else.

This discussion has been closed.