[.438 beta 5] Fix your s**t software

After upgrading to beta 5 .438 version from stable pie .087 the device is not certified and many DRM content protected application becomes unavailable.



  • kumardaksh314kumardaksh314 Level 1
    edited January 2021

    The developers at ASUS compiled the build with the fingerprints not matching with Google's.

    My device still stays uncertified after 20 days of upgrade from 087 Pie to 438 beta.

    I never unlock bootloader. Now some banking apps says I'm rooted even though I'm not even unlocked once or ever.

  • Hi drshtmstry

    As your previous thread, both of your CTS and Google Play Store certification are fail, leading to contradict the apps involving security authorization such as Netflix.

    As I mentioned before, my device doesn't have the same issue after upgraded from Android 9 to V438 (To test other issues, I had switched my device between Android 9 and Android 10beta for more than 5 times yet I have never faced a certification issue), please downgrade your device to Android 9 and upgrade again, then wait one week for system synchronization. (Remember to backup the data first.)


    Please avoid any overlapping thread or message, which may disturb the mods and the users to solve the issue. 


    1. Have you ever repaired your device or change your motherboard before? If so, please provide me your ASUS RMA no. for further checking.

    2. Have you ever flashed custom rom/flashed wrong firmware/rooted/unlocked your device before?

  • 1. I have never repaired or opened my phone in neither service center nor outside. Never changed motherboard.

    2. I haven't unlocked bootloader. Or used custom rom for that matter.

    3. I have tried downgrade & upgrade 2 times since the firmware was launched. But even after waiting for 1 week, it still shows uncertified. And this is not only me, others on the forum are also reporting same thing.

    According to google search, if the update is not signed and verified by Google, then CTS profile don't match & device fails SafetyNet test.

    This is common for custom ROM because they are not approved by Google. But this is an unexpected behaviour for stock ROM provided by company.

    Please get your builds approved by Google before releasing them publically.

  • Thank you for your reply. Please check your inbox and provide me your SN and IMEI for further checking.

  • This issue is not faced by everyone. I have upgraded to version 438 from .87 pie. I didn't face this issue

  • kr_raushankr_raushan Level 1
    edited January 2021

    This issue is also faced by mee


    [2021/01/26 edited by mod @Christine_ASUS]

    Added Info: raushanpandit718 reported that he got certified automatically on 22th January.

  • How did you upgrade? Then tell us instead of simply telling you didn't, that doesn't help. Many people still has this issue & few don't.

  • I downloaded the package from asus website and placed on root folder of internal storage. Then the update got detected and I updated it.

  • Sent all the screenshot & imei, serial number etc details to @Christine_ASUS and after that she told me to downgrade to pie.

    In pie also sent all the screenshot of Device certified & safetynet passed to Christine.

    Let's wait for maximum of 2 months. After that it's not worth it. After 2 months, I plan to unlock bootloader and move on to custom rom like many other users.

  • I told you Beta build has fingerprints mismatch issue with Google & also banking apps says its rooted, so definately there's something wrong with the beta build.

    Its either @Christine_ASUS using seperately compiled build or God knows its affter differently. She don't has late incoming call bug either.

    Please Christine give us one last update which solves these 2 bugs we won't ask more:-

    1- late incoming call bug

    2- CTS pass bug.

  • VXPVXP Level 1


    This bug is present on a few phone revisions. Zenfone phone revision - is a first two symbols of your serial number. Mine is K2, but unfortunately I'm too afraid of upgrading to A10 beta to test this issue.

    I know that J8 (and sometimes J9) revisions are affected by this certification bug.

  • After communication multiple times with @Christine_ASUS and providing all the details & screenshot, she told me to downgrade to Pie.

    After a week, now she has confirmed that Asus developers are unable to fix this problem.

    It is time to say goodbye to stock ROM.

    Developers wasted 1 year of time of all users by promising A10 but failed to deliver it.

    On latest Pie, still the security patch is outdated & battery drain has increased.

    It is time to switch to custom ROM, for better security & battery backup.

  • Another reason to fix this.


  • kumardaksh314kumardaksh314 Level 1
    edited January 2021

    @Christine_ASUS Serial Number starting with J7 aren't affected but mine L2 is uncertified.

    It's not rocket science for your developers to solve this issue.

    leave the delay call bug but atleast let us have our device certified & *CTS pass on a locked bootloader.

    Please get done with this issue.

  • Bro, you reset your device after installing the beta build because it worked for me so don't blame developer just a factory reset solve the bug.

  • Vro, i finally reset the device but cts still fail.

    After much time is shows certified?

  • kumardaksh314kumardaksh314 Level 1
    edited January 2021

    @Christine_ASUS , I downgrade to Pie and upgraded to 087 from OTA my CTS was PASS & Play Store was CERTIFIED.

    But after upgrading again to the 438. CTS Failed again. There is some issue in the beta ROM.

    Kindly look at the Pie CTS & Play Store status.

    Sadly on 438 after upgrading again.

    There is some issue in the beta ROM in its build fingerprints. It's causing issues in different device models.

  • kumardaksh314kumardaksh314 Level 1
    edited January 2021


    There must be some devices missing in the beta build cts fingerprints thats why Google isn't catching up some devices.

    Please @Christine_ASUS get this issue solved. It is clearly an error from devloper side.

  • I would like to ask whether the device that has not been used for Safety net is only available in 3/32GB version. I have a 4/128GB device that has Safety net, and a 3/32GB device that has not been used (only after it is reduced to A9)

This discussion has been closed.