speaker mode ; phone not charging ; discord copy pasting text with [ ], front camera issue

EhmtEhmt Level 1
edited February 2021 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: ROG 3
  2. Firmware Version: 4.19.81
  3. Rooted or not: No
  4. Frequency of Occurrence: All the bloody time
  5. APP Name & APP Version (If your issue relates to the app): See below



Issue 1: Whenever I make calls and put the phone on speaker, the person hears themselves echo with feedback and/or cannot hear me at all. The issue only seems to occur with the person on the other line. I can hear the person fine.

Issue 2: I bought this phone when it first came out in Australia. I've only had it for a few months and suddenly the phone is not charging properly. I have read previous posts but they are from back in September/October and it is now December and I am still facing this issue. It is not that it is not charging. BUT it is charging at a snail pace despite representing that it is "hyper charging". I have seen the phone fast charge and this isnt it.

Issue 3: Discord (whatever the newest version is on google play) -it's a chat app. One of the games I play records information in something like [1111,000,113231,1111]. When I copy that text from discord, the phone doesn't pick up the closing square bracket which makes it extremely frustrating to copy paste stuff.

Issue 4: Front camera doesn't seem to work AT ALL. I never usually use this function but the other day i accidentally switched to that mode and all I could see was black, in spite of me being in a well lit room. I confirm there is nothing obscuring the front camera.


I tried reaching out to ASUS and I spoke to some guy Anthony. He was probably the most useless support I have ever come across in the IT industry and I will be submitting a complaint about him when I get a chance.

In any event, the absence of assistance from Anthony led me to do some self help and then I come across this forum. A quick browse suggests a number of users are facing the same or similar issues.

Would you please inform me in this message thread so everyone else can see (instead of PMs as it seems it is not open for me to instigate a PM-chat with you), what steps we can take to try and resolve this fix ourselves and if not, when a patch will be distributed? The phone is very new and the natural inference is for users who have this as a brand new phone is that it is a software, not hardware issue.

Steps I've taken

I tried testing safe mode and the result is the same in relation to the charging issue. Snail pace charging. Everything is in mint condition so it must be software.

In relation to the speaker mode issue whilst on a call, i have conducted the board mic tests but can't seem to tell if anything is wrong


  • I suggest you wait for the December FOTA update and if that doesn't fix your problems then do as you wish,take them to court,as I remember you have some customer rights

    Also on the 4 issue I think it has something to do with hardware and for the charging too

    I think it's covered in the guarantee as it was advertised to you as working splendidly

    Other than that I can't give more advice since I haven't encountered any of these issues

  • Thanks, is there any indication regarding when the FOTA update might be?

    I know about my consumer law rights but it is an absolute nightmare trying to take advantage of those statutory rights, not to mention time consuming.

    I was hoping to get some assistance from Asus who have provided private messages to people with trouble shooting steps which by inference seems to have resolved some issues (because they don't seem to have reposted).

  • bumping this post as i have not had a proper response from asus

  • EhmtEhmt Level 1

    ok just going to get the phone replaced, useless support.

  • @Ehmt Sorry for the late reply, I seem to have missed your thread when you made it.

    Do you still have your device or has it been replaced or returned since your last post?

This discussion has been closed.