Fast charging Zenfone 6 Edition 30 broken AGAIN

JoraiJorai Level 1
edited December 2020 in ZenFone 6

Please tell us some basic information before asking for help:

  1. Model Name: Asus zenfone 6 (Edition 30)
  2. Firmware Version: Not listed in my phone's hardware information - Am on latest Android 10 update
  3. Rooted or not: No
  4. Frequency of Occurrence: Random
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


When I bought the phone the moment it was released, fast charging seemed to work fine. After its first update it stopped working and I have sent the phone and the charger plus brick to Asus repair. ASUS Service no= E2003132020.

After I received it back, fast charging seemed to work for a while and then after two weeks it stopped again. A few weeks later it worked again for almost 2 months and now it stopped working AGAIN. Absolutely mind-boggling. It just says "charging" instead of "fast charging".

It's impossible for me to pinpoint what causes this issue, and the guys at the repair center seem to know nothing either as their repair note (translated from Polish) claimed that 'they were not able to found an issue and that the user might experience problems with charging due to charging it "the wrong way".' What does that even mean? I'm using the original brick and cable and I plug it in like anyone else.

Sending my phone back a second time to asus repair is definitely not something I'm keen on doing. I really hope that somebody in this forum can give me a satisfactory answer how this issue can be solved. If more information is required and more than happy to provide it.

I decided to put my trust in Asus and went for this (more) expensive version of the Zenfone 6 because I finally managed to save up for, what I thought, an extremely decent smartphone. Instead, I ended up with the most expensive phone I ever bought that has more issues than any device I owned. I know this isn't the place to vent but I just needed a few words to say how incredibly disappointed I am in the Zenfone 6. It's very unlikely I will buy another smartphone from this brand in the future.


  • Hi , try to install Accubattery app from playstore ,and check charging current ,when phone is just charging . If plugged to pc usb port , 250-500ma , if plugged to 5v 1-2A generic charger ,it will be about 950ma ,with original charger more than 1,5 amp . All this true if usb cable and phone usb port are okay. If data connection pins broken on cable or socket , charging will be limited to 500ma as from pc usb , and you will see only "charging" . But it may be also software issue . Interesting would be see app screenshots .

  • In 8 out of 10 cases it's the cable that's broken. In the other cases it's either the phone or charger.

    So please buy a new cable and try. If you get fast charging again (with the ASUS charger), then (if you still have warranty) you can claim a new cable from ASUS

This discussion has been closed.