Charging stucks on 98%

ZT-5df0c960ZT-5df0c960 Level 1
edited November 2020 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: ROG phone 3
  2. Firmware Version: latest
  3. Rooted or not: no
  4. Frequency of Occurrence: last few days
  5. APP Name & APP Version (If your issue relates to the app): battery/ system

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.



  • Please check this screenshot as a reference

  • Hi [email protected],

    How much time have you check it is stuck at 98% ?

    Make sure you are on latest software version which is .78, you can check by

    Go to setting => About => Software information.

    You can check under safe mode.

    Hold power button for 5 seconds => When the screen flashes with option => Press & hold power option => You will get an option to restart in safe mode.

    Factory reset your phone once if this doesn't help.

  • I have already mentioned that i have latest one.

    Please do confirm.


    I have tried in safe mode, with & without schedule charging, with & without slow charging..

    Even my primary charging port doesnt work anymore. Charging with that port, screen lights up like there is some current or power fluctuations.

    And secondary port got losen. Its not a month yet.

  • Try to factory reset your phone, Sr. Wkwkwk what the hell. All of our question, the answer is...

  • xihexihe Level 2

    The answer is... Have you factory reset yet? Have you tried running the battery down to 0% and charging to 100%?

This discussion has been closed.