Notification LED

nuccionuccio Level 2
edited November 2020 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: Rog Phone 3 Global
  2. Firmware Version: latest
  3. Rooted or not:. Not
  4. Frequency of Occurrence:. Constant
  5. APP Name & APP Version (If your issue relates to the app): all apos

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


My front notification light does not flash when there are notifications. This is happing with the latest firmware as well as the last firmware. I have factory defaulted my phone , which is a right pain in the arse to have to do and iit has made no difference. The system light on the back flashes with notifications, the front does not.

Not sure how many times I need to start a new thread on this issue before Asus reaches out to me, but so far I have heard jack shit from them. I need this to work. The front LED light works as it comes on when charging. So it has to be a software issue.


  • Can anyone offer any help with this issue, kinda seem ridiculous that I need to download 3rd party apps to get notifications to work on this phone

  • ping the mods with a @

    they might respond.

  • @Anders_ASUS

    Can you provide any help?

  • Try enabling and disabling the notification led option in settings!

    If not this might even happen if u drop ur phone! Due to that impact!

  • edited October 2020

    @nuccio Sorry for the late reply, I could've sworn I made a post earlier.

    Go into Settings -> Display -> Scroll down to Light management -> Toogle 'LED indicator' on

    You can also press the text, which will reveal more settings. Make sure that all settings on that page are enabled.

    You can also try flipping everything on/off to see if that takes care of it.

    Mention me in this thread if you don't get it to work doing the above.

  • @Anders_ASUS

    I have tried disabling and enabling LED notification in settings and it has made no difference. The only app that works with the notification LED is GMail. Missed calls, messages, Outlook, Whatsapp etc, none of these light up the notification LED when there is a notification. I have even factory defaulted the phone and started again and it has made no difference.

  • I have tried all these methods but it didn't go with them . It's a bug which came with the .58 update as I noticed it from that day and hasn't gone since then .

    It wasn't there before .58 update

  • @nuccio I'm sending you instructions on how to log your device, so our developers can take a look.

This discussion has been closed.