Cannot upgrade/downgrade my Asus zenfone 4 ze554kl. help!

reza.siami1380reza.siami1380 Level 1
edited October 2020 in ZenFone 4 Series

Please tell us some basic information before asking for help:

  1. Model Name: Asus zenfone 4 ze554kl
  2. Firmware Version: PPR1.180610.009.WW_Phone-16.0620.1910.19-0
  3. Rooted or not: No

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


I just want to upgrade/downgrade my firmware but i see this when i want to do that:

E: Failed to mount /factory: Permission denied

E: Failed to mount /asdf: Permission denied

Supported API: 3

[phone status]

E: Failed to mount /asdf: Permission denied

E: Failed to mount /asdf

E: failed to set up expected mounts for install; aborting

Installation aborted. ***

I tried it with SD Card too but it doesn't work too.

i still can use my phone but i just wanna upgrade it to the latest version firmware and i cant :'(

please help me to resolve thins issue.

i attach some pictures below 👇️

thanks for attention


  • I got the same problem and oppened another topic like yours ! But i felt there is nobody on this site do answer any question ! Seems this is a fake support site from asus ! Sorry to you and me ! Try google , youtube , or somewhere else !

  • Yes it is. But I solved my problem 😁

    If you want help to solve it, I can help you =>

  • Hi friends

    Thank you for your asking. You may also try to access recovery mode for performing the Factory Rest first; download the firmware file in the computer; put the file into the root directory of internal storage via USB; then perform the rest.

    Please try the following steps to access recovery mode for the Factory Reset:

    0. Try to back up your data with USB cable

    1. Power off the phone, then keep pressing "volume down key"

    2. Press "power key" and stop press " power key" once you feel the vibration. Still keep pressing "volume down key".

    3. Stop press "volume down key" once you enter [Android Recovery] Screen

    4. Choose "Wipe data/factory reset">"Yes"

    5. "Reboot system now"

    #Hardware Reset Guide

    Please note that once the steps are completed, all data, apps, settings and personal information will be deleted.

  • It'll not work, if you see the photos it's locked and will just work on TWRP for flashing phone. I spent my 3 day and night to find the way and solve the problem.

  • Hi reza.siami1380

    Thank you for your sharing. Because Root, Unlock, and TWRP do not belong to ordinary operations, you may share your solution here for other power users :)

  • Mohon bantuannya kak apl error semua

  • Hi ziwi12345

    Thank you for your asking. Are you asking about the issue of all apps can't open? Kindly try some stay-at-home troubleshooting tips below:

    1. Settings>Apps & notifications>App info>3 dots on the top row>Reset app preferences

    2. Please try "the Factory Reset" 

    Settings>System>Reset options>Erase all data(factory reset)

    Please note that once the Factory Reset is completed, all data, apps, settings and personal information will be deleted.

    If the situation remains the same after performing the Factory Reset, please contact ASUS repair center in the country of your residence:

    If it is impossible to access the service center during Covid-19 period, please try Call us:

This discussion has been closed.