Google Chrome & Android System WebView is not getting updated from Play Store. Need Help ?

safalsafal Level 1
edited October 2020 in ZenFone 5 Series

Please tell us some basic information before asking for help:

  1. Model Name: Zenfone 5z
  2. Firmware Version: QKQ1.191008.001.WW_user_100.10.107.99_20200906
  3. Rooted or not: Not Rooted
  4. Frequency of Occurrence: Always
  5. APP Name & APP Version (If your issue relates to the app): Google Chrome & Android System WebView

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


I've tried restarting phone.

I've also tried Force stopping Play Store, Google Chrome and Android System WebView & clearing cache of Play Store, Google Chrome and Android System WebView.

But no solution

Need help 🙏


  • I had faced this issue 2-3 months ago and factory reset solved my issue.

    If u really need to update these apps then reset your phone.


  • Thanks but That's a lot of data to restore. If I do factory reset.

    I need better solution !

  • Alice RenautAlice Renaut Level 1
    edited September 2020
    1. Disable Google Play Store and Google Play Services.
    2. Restart the device.
    3. Activate both apps again.

    Let me know if that helped.

  • Hi Alice...if we disable Playstore and play services,will it affect working of Android system or smooth working of any other app

  • Alice RenautAlice Renaut Level 1
    edited September 2020

    It is a risk you will have to take.

    As far as I know, there's no harm until you open applications without first reactivating Google Play Services.

    At the end of the day, it is this or reset to factory settings. 😓

  • Hi, we'd request you follow the below steps:

    1. Clear system cache.

    2 . Disable/ re-enable the apps.

    3. Try the same under safe mode:

    Hold the power button for 5 seconds => When the screen flashes with option => Press & hold power option => You will get an option to restart in safe mode

    4. If still you face the issue

    factory reset your phone after taking a full backup :

  • I was also experiencing this issue, it is due to trichrome library not updated, try this, clear data of play store, then connect with wifi, now open play store, it will automatically update trichrome library

    If this is not working, then manually download trichrome library from apkmirror, then install, then update web view, then update chrome

  • Hello again, @safal and @ramans059!

    It just happened to me and the solution was exactly to erase the data from Google Play Store and Google Play Services. You can erase, restart the device and enter the store that Chrome and WebView will be able to receive the pending update.

    No error occurred during or after the procedure, you both can do it without fear.

This discussion has been closed.