I installed FOTA update today, but now my phone is not booting up.

yogendrappathakyogendrappathak Level 1
edited October 2020 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: Rog 3
  2. Firmware Version:
  3. Rooted or not: Not
  4. Frequency of Occurrence: 1st occurrence
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


During installation of FOTA updates, my phone went into reboot mode and its already more than 3 hours, but it has still not started. Attaching screenshot.

I have tried to enter recovery mode, but after releasing power button on android screen, it doesn't get into recovery mode and again the same screen as attached in screenshot appears.

Any help here would be appreciated.


  • Hi,

    Can you confirm if its still under loop?

    Also, was it with .70 update which was released yesterday?

  • Hi,

    I have the same issue.

    It stayed like that for at least 5 hours until it turned off due to battery.

    I can confirm it is an issue with the latest update (September 21st), because I ve seen more than a dozen users complain about the same exact rebooting after update error.

    I have the 16GB version and it is exactly one week old.

    Thanks in advance.

    Best regards,

  • Hold volume button down and up and power button to force shutdown.

    from off press volume button up and power on this well send you to Fastboot and press volume up to switch boot to recovery then press power button. then you can factory reset if you want.

  • I got 2 units, one of the unit facing same problem, after force restart can't receive the ota update anymore

    This is the first rog and will be last rog for me

  • Hi @yogendrappathak,

    Awaiting your details in PM.

    You can try below if your phone is stuck in loop.

    1. Press Power + Volume Down (force restart)
    2. Keep repeating till your device reboots or takes you to the recovery screen
    3. Your device may also boot in normal mode and may popup as update failed 
  • Hi

    If you are stuck in a boot loop, please press Power+VolDown for 8seconds to force a restart.

    Force it to restart at least 6 times if it fails. It should fall back to recovery partition after that.

    Can you also pass me your SN/IMEI for the affected device, it may help us study the issue if related to anything in upstream process.

    Thank you

This discussion has been closed.