ROG 3 not charging.

sayak.4ndzsayak.4ndz Level 1
edited October 2020 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: ROG 3
  2. Firmware Version: 17.0823.2007.47
  3. Rooted or not: Not rooted
  4. Frequency of Occurrence: Everytime
  5. APP Name & APP Version (If your issue relates to the app): On Factory Reset

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.



  • Day before it completely died.

    I noticed it was not charging while the phone was on. Switched it off and it charged up. 31st Aug

    1st Sep: Noticed charge icon was showing up on plug with ++ icon on the battery and immediately disappearing.

    Tried with other chargers - same.

    Purchased on 1st sale - cannot return.

    Covid19 - cannot visit a service center.

    Purchased my most expense phone yet and came with it this much trouble. Trusted the brand and jumped for it, being hopeful that I will get some help.

    Tried fac reset/2 other mi chargers -18/10 watt.

    Doesn't work while powered on/off.

    Not sure but it might have started after I played around with the battery master.

  • So contacted Asus CS today morning, and to my dismay during these pandemic times asked me to visit the service center.

    Seems like there's just 1 in WB so far from my location. Will need to spend 1.5k for 1 trip, and if they decide to keep the phone then 3k.

    For the last 6 years I was stuck to a particular phone brand and never I had to visit the service centers. Changed brand and purchased the most expensive phone yet and there you go.

    This is sad.

  • @sayak.4ndz Is it the same with both USB-C ports and all your chargers? Also, which firmware are you currently on?

    If you're up for it, you could log your device so I can pass it on for some further investigation.

  • Same on both ports.

    Firmware: WW_17.0823.2007.58

    Something more I noticed - somehow it charges a bit after connecting the charger that's also very slow and stops after 1-2% increase.

    Ready to share logs, but how?

  • Receiving the worst experience of my life. Went this far to a service center. Now they are saying cannot submit this device as the link they use to register and submit the device is not working.

    No regards for customer time/safety. Just selling off products and no after sale service.

    Would anyone confirm if I need to place a customer consumer court complaint?

    Selling phones with price equivalent to iPhone, this cannot be the expected customer experience.

This discussion has been closed.