Asus Zenfone Max Pro M1 Google Pay

VlczechVlczech Level 1
edited October 2020 in ZenFone Max Pro Series

Please tell us some basic information before asking for help:

  1. Model Name: Zenfone Max Pro M1 ZB602KL
  2. Firmware Version: WW-17.2017.2006.429
  3. Rooted or not: original - not modified
  4. Frequency of Occurrence: always
  5. APP Name & APP Version (If your issue relates to the app): Google Pay 2.112.312533666

In previous (beta version) of Android 10 (I think, that it was WW-16.2017.2005.082), I was able to pay by Google Pay with my card. In this version I'm not able to pay, because device is not certified. It is quite strange / confused, that in beta version Google Pay is OK, but in next version it is broken.



  • Hi Vlczech

    Thank you for your asking. WW-16.2017.2005.082 is Android 9 version and WW-17.2017.2006.429 is Android 10 AOSP Software Image developer Version :) Kindly provide the information below so that we can better assist you.

    1. Please assist me to confirm your current firmware version. Did you perform manual update from WW-16.2017.2005.082 to WW-17.2017.2006.429?

    Settings>System>About Phone>Build Number

    2. Please check on SMMI test , does it fail?

    Calculator> type ".12345+=">SMMI TEST>Single Test>NFC Tag Reader Test

    3. Please try to enter "Safe Mode". If the function works well in Safe Mode yet the issue remains out of Safe Mode, please check on any disturbance from the installed 3rd party apps.

    # How to enter and exit "Safe Mode"

    4. Also, please try "the Factory Reset" 

    Settings>System>Advanced>Reset options>Erase all data(factory reset)

    Please note that once the Factory Reset is completed, all data, apps, settings and personal information will be deleted.

  • I am on 429, device is certified and used gpay to pay many times.

  • VlczechVlczech Level 1

    @Christine_ASUS :

    1) Yes, I manually update firstly from Android 8. to 16.2017.2005.082 ( I hope that it was this version, but I'm not sure), then I manually updated to this Andoid 10 AOSP. BTW: Is it possible to upgrade from .429 to new 16.2017.2007.084 (is this update od Android 10 AOSP?)?

    2) I don't have any NFC device here at the moment, so I will try as soon as possible

    3) Also on Safe mode the device shows, that is not certified.

  • VlczechVlczech Level 1

    I tried to delete cache and data of Google Play, information about "Device not certificated" disappeared - but there is no information about certification right now (if is it certificated or not). It disappeared whole the item "Certification Play Protect".

  • YachendraYachendra Level 3
    edited July 2020

    We can't downgrade directly from Android 10 .429 AOSP to new Android 9 firmware.84.

    1) For that you have to downgrade to Pie with any of the fastboot ROM which is lower than .84 version so that you can upgrade later with .84.

    2) I didn't tried this: You can try to downgrade from .429 to Pie .60 version with downgrade firmware available in Asus website(It's released to downgrade from Android 10 firmware version .407 to Pie .60 version, don't know whether it works from 429 to 60). If not work you can follow step 1.

    Suggestion: Do hard reset after downgrading and updating to latest version of Pie so that you can get better battery backup.

  • Hi Vlczech

    Thank you for your reply.

    BTW: Is it possible to upgrade from .429 to new 16.2017.2007.084 (The latest Android 9)?

    To determine weather this firmware version is Android 9 or Android 10, please regard the primary numbers of the firmware version. e,g. WW-16. is Android 9 and WW-17 is Android 10

    And yes. You can downgrade your V429 to V084 by the following steps below

    WW-17.2017.2006.429>SD card downgrade with Version MaxProM1_downgrade_to_9>WW-16.2017.1912.060>Manual update>WW-16.2017.2005.082>Auto update>WW-16.2017.2007.084

    #ZB602KL Firmware Spot

    # SD card downgrade guide

    #Update Guide (Manual)

    Please let me know your SMMI test result or your NFC works in WW-16.2017.2007.084 or not. If you have any further queries, please do not hesitate to contact me.

  • Try to disable the playstore version and it will ask to replace with factory version (which will downgrade to older app version and delete data). Again you update the app. Try this for Google Play services also and check it might work.

  • @Christine_ASUS & @Yachendra: Ahh, OK, I didn't know, that it is Android 9. I tried SMMI NFC test (on this Android 10 - WW-17.2017.2006.429) with another NFC device: it seems, that NFC chip responded, if there appeared message "Click to transfer" as the devices approached each other.

    @Yachendra : What did you mean by following? Did you mean Google Play app?

    "Try to disable the playstore version"

  • BTW: Google play store is OK, i can download apps and update apps without any problem, but only Google Pay does not work due to this "Uncertified" ("Device not certified") state.

  • Hi Vlczech

    Thank you for your reply. Because your SMMI test is fine, indicating that the hardware is fine. Have you tried the factory reset? If the situation persists after performing the Factory Reset, kindly let me know.

  • Screen from Google Pay (translation: failed to set up payments in stores. This device can not be used for payments in stores. It may be because device is rooted or modified.) after clear cache and data of Google Pay and card registration again:

  • Same issue here - I am unable to add card to google play to pay in stores. Further checking Safety Net says that 'CTS profile mismatch' does not allow it.

  • Hi Vlczech &

    To avoid any misunderstanding, kindly provide the information below so that we can better assist you.

    1. Your current firmware version

    2. Did you perform the Factory Reset?

    3. Does the issue appear after any system/apps' download or update?

    4. Please provide me the video of the issue

  • @Christine_ASUS :

    1. I wrote it in the initial post: WW-17.2017.2006.429
    2. I'm not a fan of factory reset, but I did it.
    3. It's still the same
    4. "Finish the setting on a new device / phone":

    "Card selection - use the one, which is stored in Google account"

    ...Take another screenshot was blocked for security reasons... But I must check expiration of card, type CCV code and check the card holder name, address... After confirmation of this the same result occurred: "Failed to set up payments in stores. This device can not be used for payments in stores. It may be because device is rooted or modified."

    ...And still "Uncertified device" in Google play same as here:

    ...but now the Google Play Store version is: 21.4.15-21 [0] [PR] 325538472

  • Hi Vlczech

    Please try the troubleshooting tips below

    If the issue remains the same, please check you inbox and provide me the logs for further checking.

  • @Christine_ASUS : No, the main problem is that device is recognized as uncertified:

    I also tried to add card to google pay via bank app, but with the same result "Failed to set up payments in stores. This device can not be used for payments in stores. It may be because device is rooted or modified." ( )

    BTW: I'm from IT branch, so please, try to identify, why device is uncertified and solve this problem and do not tossing me from side to side like a hot potato. Thanks.

  • edited August 2020

    Hi Vlczech

    Because other users reported that their google pay work can work properly, please try to clear storage of your Google Pay

    Settings>Apps & notifications>App info>Google Pay>Storage & cache>Clear Storage/Clear Cache>Wait for few minutes and re-try certify your cards

    If the situation remains the same, please check your inbox and provide me your bug report via PM to avoid any personal information leaking.

  • I confirm that i have exactly the same issue, clearing cache for play store and google pay does not work because device remains uncertified.

    As I mentioned earlier - SafetyNet - that is checked by Google Pay throws an error saying that there is CTS profile mismatch.

    Please provide a way to collect logs and send to help to isolate and resolve this issue.

  • Hi

    Long time no see! Please provide me your current firmware version and check your inbox to provide me your logs. Thank you.

  • Hi @Christine_ASUS ,

    thank you for the instructions, I did following steps:

    1. I downgraded to Android 9, did full reset and tested Google Pay - it was working OK, Google Store said that Device is certified. Therefore the issue is not with my particular device/hardware
    2. Right after that I upgraded to Android 10 build 429 and the issue reproduced - Google Store said that 'Device is NOT certified' and Google Pay did not add the card for in store payment.
    3. Right after that I created bug report that I sent you in private message.
    4. Please let me know if you need any other info / tests / logs from my side to proceed with fixing this bug.

    Thank you in advance for your help

This discussion has been closed.