Phone restarting when sim inserted

I recently bought the ROG Phone 6 Batman edition and the phone works fine until I put my sim into it.

When the sim is inserted, the phone comes up with 'factory data resetting' and then restarts. Then comes up with an error saying 'Can't load Android system. Your data may be corrupt, If you continue to get this message, you may need to perform a factory reset and erase all user data stored on this device.' I have the option to try again or factory data reset. I have reset it a few times and it seems ok. As long as the sim is in before I reset it the phone will work fine but if the phone restarts for some reason after it has been reset then the issue starts again and I have to reset the phone again. Does anyone know how to fix this issue?? any advice would be greatly appreciated

Comments

  • I believe this is a new one.

    So what youre saying is, if you factory reset your phone with the sim card and set everything up itll work fine, but the moment you have to restart the phone, it will tell you "Can't load Android system"?

    @Mattias_ASUS No idea what this is, but sounds funky.

  • Yep that's what happens ☹️. Not sure if it's a phone issue or a sim issue but the sim works fine in my old phone.

  • given the horrible state of the Rog6, its most certanly a Rog6 issue. Could you check if your phone has a small bend? just lay it on a flat table and see if it bends slightly, I suspect flex damage.

  • I can't see a bend and I tried rocking it but couldn't feel any movement.

  • maybe try and blow into the sim card slot and see if any dust etc. is getting out.

  • Can't see anything coming out.

  • Symptomatic of a SIM card problem, but hey, we are in the presence of an ASUS, then!

    Version 8 Gen 1 or Dimensity 9000?

    Have you tried the SIM 2 slot?

    The correct functioning of the SIM on an old phone does not exclude an incompatibility of this SIM on a new Phone, (Which old phone, date of the SIM?), requesting a new SIM is necessary to diagnose if this is a problem Firmware, SIM card, drawer problem

  • anyx313anyx313 Level 1
    edited November 25

    Hi,


    I have the exact same problem.

    I bought The Batman Edition and did the whole set up and everything worked fine until I put the sim card in the phone.

    Than it showed the message "com.android.phone stopped working" and started restarting, asking for a factory Data Reset.


    After few tries, I returned the phone and ordered the new one, but the same problem all over again. I even bought a new sim card ,but nothing helped .

    Even after many talks with the Asus Team, I still wasn't able to fix it. So basically the phone works great, but without the SIM card

  • Lol, now it's certain, it's a game console that's shaped like a phone

    Finally a bad console on the Batman Médiatek version if ASUS duplicates the wifi bug which has worsened with the new firmware of the 6D, there will therefore be no more mobile network or usable wifi, ASUS increasingly strong 😂

    toutx313, paradoxe_choisi

    Which version do you have, Qualcomm or Mediatek

    https://rog.asus.com/phones/rog-phone-6-batman-edition-model/spec/

  • anyx313anyx313 Level 1
    edited November 28

    I have the MediaTek version

    @FunBike31

Sign In or Register to comment.