rog phone stuck on certain version cant update or downgrade

Please tell us some basic information before asking for help:

  1. Model Name: Asus ROG Phone II 
  2. Firmware Version: 17.0240.2108.103 android 10
  3. Rooted or not: idk tbh
  4. Frequency of Occurrence: well every time i try to update ?
  5. APP Name & APP Version (If your issue relates to the app): google pay ect

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

so short story i guess would be that my phone broke i went to get it repaired i did and i also asked for android 10 cause i saw that there were updates for it got it back after 2 months then now am trying to setup google pay or install McDonalds app {for free drinks } and it says my phone is rooted so i tried to update it and well it says system update failed and i tried everything i saw online and haven't fixed it yet i need it for school so if someone knows how to fix pls tell me how to .

Comments

  • Hi roksarastauskas,

    I apologize for the inconvenience this is causing you. When you update it do you put the zip file in the root directory of your phone?

Sign In or Register to comment.