No phone service or wifi calling.

sipahi061sipahi061 Level 2
edited November 15 in ZenFone 9

As I mentioned before and no one cared to responded to. I was sold the global version even though the seller said it was the US version. I use T-Mobile. After update 32.2040.2040.23 my phone does not have any cell service and wifi calling doesn't work. Is there anything that can be done. When my phone was running on 32.2030.2030.26 it was working great, I had phone service and wifi calling. Whatever mobile data and wifi calling settings were changed for the update, made it impossible to use the global version in the US. I have contacted the seller about returning my phone but they aren't responding. I purchased the phone using Asus website which linked to Amazon. Why wouldn't Asus sell the phone directly from their website ? why would they sell it through a third party website allowing for people to get scammed ? And now no one is helping out with this and customer service is absolutely clueless and unwilling to do anything.

Tagged:

Comments

  • mickey10021mickey10021 Level 2
    edited October 5

    A new firmware was released today with updated APN list. Can you check if it fixed for you?

    https://zentalk.asus.com/en/discussion/64545/221005-zenfone-9-ww-32-2040-2040-28#latest

  • keren_ASUSkeren_ASUS admin
    edited October 6

    Hello @sipahi061

    I'm so sorry to hear about the issues you're facing with your ZF9. Is the cell service and wifi calling working now with the latest update?

    Our only authorized sellers are Advance Mobile and ASUS. (*updated info).

    Can you send me a DM with the SN of your device and the link from where you purchased? Thank you!

  • sipahi061sipahi061 Level 2
    edited October 6

    @keren_ASUS I downloaded the new firmware released today 2040.2040.28 it seems like the cell service is a little better but still no wifi calling. It appears that the phone doesn't have wifi calling by default and only after entering *#*#3642623344#*#* in the keypad, wifi calling appears in the settings but it still doesn't work, I've disabled and reenabled wifi calling through my carrier, reset the phone, took the simcard out still no wifi calling. I couldn't figure out how to DM you but my my IMEI is 351694450141192 and when I try to post a link to this comment it says I'm too new to post a link to the comments.

  • @cilsoe it was available on my phone in the system update as of 10-5

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.