ROG Phone 1 hard bricked out of nowhere

xenia1238wxenia1238w Level 1
edited November 11 in ROG Phone

Please tell us some basic information before asking for help:

  1. Model Name: zs600kl
  2. Firmware Version: Android 9, not sure which one exactly
  3. Rooted or not: no
  4. Frequency of Occurrence: always
  5. APP Name & APP Version (If your issue relates to the app): -

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

I was using my phone normally when it froze and the speakers made a beep sound, so I held the power button for 10 seconds. The phone was rebooting and I saw the ROG logo but it never vibrated or changed color as usual, instead the screen went black after about a minute, it's stuck in EDL mode since. I had no luck finding the fitting firmware for this phone. I had this phone for about 3 years and then it broke. It was perfectly fine before, no damage at all. Asus wanted to replace the motherboard of the phone for a way too high price, even if they could have just flashed it because there clearly is no damage to the hardware. I don't know what to do anymore.

Tagged:

Comments

  • edited October 4

    Hello, xenia1238w.

    We apologize for any inconvenience this may cause.

    I have sent you a private message for more detail information, please check.

    Thank you.

  • Before posting your copy pasta, try to read the topic first.


    Asus wanted to replace the motherboard of the phone for a way too high price, even if they could have just flashed it because there clearly is no damage to the hardware.

    @xenia1238w Its rather hard to come by a lot of sources as the phone wasnt that popular and ASUS didnt reelase sourcecode for it to make it popular among modders. The best thing I could find is:


  • @Danishblunt Thank you for your answer. I have also found this firmware on multiple sites, and I tried to flash it, but it didn't even start to flash, I'm getting an error ("Sahara fail, could not connect to com port handle"). I am not sure if there is a solution, and even if I solve it, there is still a high chance the firmware we found is not the right one for this phone. It is strange how the phone hard bricked even if I did never flash any other firmware or did other things that can cause this to happen. I was just using the phone normally when it bricked. I am careful, especially when using an expensive phone like this.

    I have also heard of ROG phones bricking out of nowhere, camera focus problem, and motherboard failing, not just for the first one, but the entire ROG phone series. There are a lot more reports of these things happening to the ROG phones than to any other phone, and you can find some of them even in the Zentalk community. You can find countless people talking about the problems on the site "gsmarena.com" for the ROG phone 5, for example.

  • The error you're seing is because you don't have the EDL drivers installed on your PC or your phone is not in EDL mode.

    As for the Rog series issues, aside from Rog3 and Rog1 all Rog phones are unreliable and die for no reason.

  • @Danishblunt I have already installed them but it tells me I have a "driver error" when I open the device in device manager. Some sites told me I have to activate test sign mode and then install the EDL drivers, but Windows refuses to do that for safety reasons. I am 100% sure the phone is in EDL mode because it was recognised as qusb_bulk at first, but then I installed the drivers and now it has a different name. Probably it is happening because of the driver error, do you know how to fix it?

  • xenia1238wxenia1238w Level 1
    edited October 12

    I forgot to reply but I did it now. I tried flashing the firmware but now I get Sahara error. I guess this isn't the right firmware or the storage is broken.

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.