Bluetooth doesn't automatically reconnect and won't show battery percentage of connected device

jeremy6652jeremy6652 Level 1
edited September 21 in ZenFone 9

Please tell us some basic information before asking for help:

  1. Model Name: ASUS_AI2202 8GB/128GB
  2. Firmware Version: WW_32.2030.2030.26
  3. Rooted or not: No
  4. Frequency of Occurrence: Always
  5. APP Name & APP Version (If your issue relates to the app): -

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

I have a Bluetooth speaker which usually connects to the last device it was paired with when I power it on. It works on every other phone I've tried but not on the ZenFone 9. Same with the head unit in my car.

The speaker also supports reporting its battery percentage via Bluetooth and this would usually show up in the Bluetooth menu of my old phone or next to the Bluetooth icon in the status bar, it doesn't on the ZenFone.

EDIT: Speaker is a Tribit MAXSound Plus and the headunit is a Kenwood KDC-BT73DAB.

Comments

  • Go to Settings > System > Advanced> Reset Options > Reset Wi-fi, mobile & Bluetooth. For iOS and iPadOS device, you'll have to unpair all of your devices (go to Setting > Bluetooth, select the info icon and choose Forget This Device for each device) then restart your phone or tablet.

  • I can't connect to my Kenwood head unit either...

  • Same issue here with my Samsung Galaxy Buds. They won't reconnect when getting disconnected once.

  • Hey @jeremy6652, does the issue persist even after the latest FW update?

  • I tried @willjoe2442's suggestion again after the update and this time it worked.


    The update alone didn't fix it.

  • Hey @jeremy6652, does Bluetooth automatically reconnect now?

  • Yes, at least with my Bluetooth speaker. Battery percentage also works now.

    My car doesn't reliably reconnect automatically yet but it was also very hit or miss on my old phone so that may very well be an issue with the headunit itself.

    As I said, the update alone didn't fix it. I had to reset my Bluetooth settings too.

Sign In or Register to comment.