Phone won't automatically switch to strongest WiFi network

MatunSMatunS Level 1
edited September 17 in ZenFone 9


  1. Model Name: ASUS Zenfone 9
  2. Firmware Version: WW_32.2030.2030.26
  3. Rooted or not: Non-Rooted
  4. Frequency of Occurrence: Daily.

========================================

Hello,

I have multiple WiFi networks at home, one from the main Router, and another from an extender.

I am used to my old phone, were it would automatically switch network when the extender's network get significantly stronger.

For some reason the Zenfone 9 will not switch no matter the bad connection from the current network, or how strong the closest is.


Does anyone know how to solve it?

Comments

  • I have similar issue where my WiFi is working well and suddenly nothing loads but I still have full bars and I check my iPhone 6 it has less bars but everything is loading quick wherears in the zenfone nothing loads so annoying. Z9 has very inconsistent WiFi connectivity.

  • Hey @MatunS,

    Have you enabled the Network preferences? (Settings>Network & Internet>Internet>Network Preferences>Turn on WiFi automatically) Or enabled the dual-band? (WiFi Settings>Network & Internet>Internet>Dual-band Wi-Fi)

  • Hi @Mansi_ASUS ,

    I do not enable "Turn on WiFi automatically", because it is location based, while this issue is inside the same house, at 2 edges of the house (not a big one, but did work on POCO X3 NFC).

    Also, dual band will not solve it since it is on the same frequency bands.

  • Yup, the same happens to me very frequently, it takes couple or seconds before it starts to load something, then it loads fine, just the delay

Sign In or Register to comment.