Google Calendar not adding events through other apps

Please tell us some basic information before asking for help:

  1. Model Name: ASUS_AI2202 8GB/128GB Sunset Red
  2. Firmware Version: WW_32.2030.2030.26
  3. Rooted or not: NOT
  4. Frequency of Occurrence: Always Reproductible
  5. APP Name & APP Version (If your issue relates to the app): Google Calendar - v 2022.34.1-469381351

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Trying to add events to Google Calendar through other apps (not directly from inside Google Calendar) does not function.

  1. I allow other apps permission to my calendar
  2. I use their feature called "Add appointment to calendar"
  3. Message pops-up displaying "Event was added to this phone's calendar"
  4. I check Google Calendar

The event does not appear in Google Calendar. This happens with multiple apps that should be able to add events to Google Calendar, not just a single one. Therefore I think it's an issue with Google Calendar or how it is utilized by the Zenfone 9.

Steps I have tried in order to fix the issues:

  1. Clear storage and cache of Google Calendar app
  2. Clear storage and cache of the other apps
  3. Go to Settings -> Apps and notifications -> See all apps -> 3 dots in top right -> Show system -> Navigate to Calendar Storage -> Force stop, Clear storage and cache
  4. Rebooted Device

NONE of the above attempts were successful. I then tried adding an event through opening the .ics file directly from withing the File Manager. The file correctly opened in Google Calendar and the event was added with no issue.

I suspect there might be a problem with how the Zenfone 9 handles temporary .ics files but I frankly have no idea.

Please respond with some other potential fixes for this issue as soon as possible.


Best regards,

Cosmin Craciun (illegalmushroom)

Comments

  • Hey @illegalmushroom!

    Thanks for sharing this. I've forwarded the issue to the R&D team.

  • Thanks for the reply. I'm wondering if other users here have encountered this problem? If it's only on my end, maybe there's something else I could try.

    If anyone reading this has tried to achieve the same thing and ended up with the same result, please post a comment as it would help me debug further.

    Thanks

  • self bump, interested to see if others are having this issue

  • Hey @illegalmushroom,

    I heard back from the R&D team, in order to assist you further, they require the following information from your end-

    • Log details
    • Video recording of the issue

    Please follow the below steps to enable the built-in log tool (Bug reporter).

    1.  Open “Calculator APP”

    2.  Enter “.19595+=”

    3.  Select the Log type according to the type of issue you want to capture. “General cases” will work for most issues.

    4.  After your selection the log tool will exit so you can duplicate the issue or wait for it to happen. Try to use the screen recorder to show your issue when possible. If you can't screen record your issue, then please take a screenshot right after the issue has occurred (as a timestamp) so we know where to look in the log.

    5.  Navigate back to the log tool via calculator and Tap "FINISH AND SHARE".

    6. It takes several minutes for the log to generate. You can exit and do other stuff in the meantime. A silent notification will tell you once the process is done. Tap the notification and then the share button to upload the file to Google Drive and share the link with a moderator. Just make sure to change the permission first so that everyone with the link has permission to view it.

    Note: When you're no longer planning on logging your device, enter “.09595+=” in the calculator and the log tool will stop as well as deleting all stored log files. Make sure to share via calculator. The files found in internal storage -> asus_log are not the correct files (they are only 1.2kb)

  • Thank you for the detailed reply @Mansi_ASUS

    Google has recently pushed an update to Google Calendar, bringing the app to version 2022.36.0-472143158.

    The issue I reported seems to be fixed after this update. I can now add calendar events in Google Calendar through other apps. Does the team still want me to provide the requested information?

    Thanks,

    illegalmushroom

Sign In or Register to comment.