Background mobile data enable/disable

For some reason my phone will not allow applications to use mobile data in the background. What this means is that WhapsApp/Signal will not notify me of new messages. I have to expressly open the app to check for new messages all the time. I know this is an issue with background mobile data because if I simply connect to a WIFI access point the apps will immediately notify me of pending messages. So the apps must have been running in the background!

The "Mobile data & Wi-Fi" settings for both apps have all settings enabled ("Background data", "Unrestricted data usage", "Enable Wi-Fi connection" and "Enable mobile connection"). I have also tried setting "Battery"->"System modes" to "High performance" and disabling "battery"->"Background app management"

Does anyone know how to configure the phone such that it will allow background apps to use mobile data.

Comments

  • Hi @Patrick 8e20c

    Thank you for reaching out.

    Does this happen with all apps or just WhatsApp?

    You can try to leave the battery management ON but then go into the WhatsApp and longpress the app icon. Then go to battery, and turn off battery management. This usually works on an per-app basis for a little more control.

  • It happened to more than one app, in my case thats just WhatsApp and Signal. I discovered what the problem was. "Background data" was disabled for Google Play Services. It seems that "Background data" for WhatsApp and Signal is not relevant, they must be using "Google Play Services" to make their background connections. Once I enabled "Background data" for Google Play Services the apps started working fine again!

  • @Patrick 8e20c

    Thank you so much for the update! I'm glad it worked out. Have a great day!

Sign In or Register to comment.