Phone is completely out

edited September 25 in ZenFone 8

My Asus Zenfone 8 just turned 1 year and 1 month old, i bought it at pre-sale here in the Philippines.

It won't charge nor will it turn on. Nothing works, charging it makes the LED light at the bottom give a red blinking indication for a couple of minutes. It will not respond to pressing the power button and volume buttons.

I tried returning it to the seller but my warranty was only for 1 year.

Comments

  • Hi @noel.fornolles18

    Hi there, we're so sorry for the inconvenience this has caused you.

    Usually, the LED indicator will light red indicating that the system is at extremely low battery status. Please try charging your phone and then turning it on.

    By any chance, did you accidently drop or damage the phone?

  • Hi @keren_ASUS !

    I did not drop it and i did try charging it for a long time but it still will not respond.

    It happened while i was charging (34%) and browsing facebook, it stopped responding so I tried to turn it restart it. But it wouldn't turn on anymore.

  • I'm so sorry about that @noel.fornolles18. Unfortunately, you will need to reach out to customer support in order to resolve this. Here's the contact information so you can reach out to them. Thank you!


  • Hi @noel.fornolles18

    It seems to be my problem as well. Exactly same symptoms, mine died when it was somewhere between 10 and 30% (don't recall exactly) and not charging. But I tried charging since, using different cables, different chargers, powerbank as well (my powerbank shows 5V/0.4A discharge rate when attempting to charge zenfone). So clearly something wrong here... And my phone was just over 1 years old as well... Clearly not "build to last"...

  • Hi @karol.wolkanin

    That's my impression as well. I hope more people who have this problem would speak up about it.

  • AntaresSquadAntaresSquad Level 1
    edited August 24

    Hi @noel.fornolles18

    Same problem happened to me around Dec 2021. It is caused by motherboard failure which used to be caused by ramdump. Search up "zenfone 8 ramdump" if you'd want to know more about it. There was also a discussion about this problem in zentalk forum.

    If you have any plans in having your phone RMA'd, you may want to check your IMEI number. My phone went through an RMA and after receiving it, while it has the same motherboard serial number, the IMEI number was changed. At least this was one change I noticed after the RMA and checking the hardware through About Phone and .12345+ or whatever trigger I can use in stock calculator.

    For now, there are no problems here with my phone even with the different IMEI number though I hope this will be the first and last motherboard failure that may occur.

  • Hi @AntaresSquad

    That's what i'm afraid of, a motherboard change costs almost the same as a new phone.

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.