Can't set dns properly for wifi

Please tell us some basic information before asking for help:

  1. Model Name: Asus ROG phone 5s
  2. Firmware Version: 31.0810.1226.91
  3. Rooted or not: no
  4. Frequency of Occurrence: always
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

I want to configure the DNS to my local IP. However, it keeps automatically add 8:8:8:8 as one of the DNS server. Even if I configure 2 DNS server, it will still add 8:8:8:8 as the 3rd DNS server.

I tried disable the private DNS and it doesn't work.

Any help on this is appreciated.


Comments

  • FunBike31FunBike31 Level 4

    Do you have a DNS server on your private network?, is it under windows server 2016 or Linux?, what does nslookup answer you - 192.168.0.102? , if you have a DNS server at home, logically you must have PCs, no problem with them and your local DNS?

  • ErikWangErikWang Level 1

    I do have a local DNS server (pihole) and other devices are connected to it, except for this phone. The problem is when I set the 192.168.0.102 as the only DNS address, it will automatically append the 8.8.8.8 as the 2nd DNS. So it just bypass my own 192.168.0.102 and use 8.8.8.8. I can't find any settings related to this. I think it is just a weird bugs for this firmware.

  • FunBike31FunBike31 Level 4

    When you say other devices, there is no Android I imagine because I think that if you test another Android it will be the same problem.

    This is not specific to ASUS but to Android/Google where there is hard dsn coding.

    You can try several things, disable IPv6 on your ISP router because I think it continues to try the dns of the router

    If you have a terminal/console application for android you can run and see if the addresses are IPv4 or 6

    getprop net.dns1

    getprop net.dns2

    You can also try to put in the 2 static DNS entries the same, i.e. 192.168.0.102 in dns1 and 2

    also check that if you use DHCP there is only the Pi-Hole one and if it is static that there is no more DHCP server (router, Box, etc....)


    4 or 5 years ago there was a specific topic at Pi-Hole, the title was something like "Pi-Hole works everywhere except Android"

    For me it's not a firmware bug, just that Google thinks it's unavoidable and will look for 8.8.8.8

  • ErikWangErikWang Level 1

    My other devices do include android. I have a OnePlus 6 and it just works. I basically duplicate the wifi settings and it just doesn't work the same in this Asus phone.


    FYI, I do tried add another random IP as the secondary, but then the Asus phone will just add the 8.8.8.8 as the third DNS IP.

  • ErikWangErikWang Level 1

    I do tried adding the same IP as the secondary, and it doesn't work as well. The 8.8.8.8 always there for no reason

  • FunBike31FunBike31 Level 4

    that's what i was saying, you don't have an android device

    OxygenOS is based on Android but unlike other manufacturers, it is not Android with an overlay, OnePlus develops OxygenOS in depth and it is fully optimized and only compatible with OnePlus devices.

    One and the other are not comparable, whereas with 80% of the other manufacturers, they just develop a few additional applications and work on the interface, but the base is Android/Google.

    That being said, this does not explain that you cannot do it, this dns 8.8.8.8 only goes up if there is something wrong in the DNS resolution 1 and 2

  • I am investigating this

  • FunBike31FunBike31 Level 4

    You should come to the same conclusions as me :)


    On Android <9 this should work, versions 9 and later only accept a DNS hostname in private dns

    The OnePlus was supposed to be in 8.1 but Android on OnePlus not being Google it is possible that compatibility with previous versions is retained.

    To use a private DNS server it must support Android devices, this is far from the case but it must be possible to have a workaround, give a dns hostname to the ip address in hosts file

    The simplest solution for users who do not have extensive network training is certainly to replace a private DNS server that is not compatible with Android device by a compatible one, such as AdGuard Home for example.

    The first question is unanswered, except as long as nslookup "myserverdns.mydomain" doesn't return 192.168.0.102 it won't work

    myserverdns.mydomain as an example of course which must be the host name of its DNS server

  • ErikWangErikWang Level 1

    I only gave u one example which is oneplus, but there are many other device in my home. From laptop, desktop, apple, and android (OnePlus, Samsung, Xiaomi, Pixel, Huawei). All works fine, except this phone.

    I also tried changed the DNS in my router directly. Again, all other device works, except this phone. Coz it just append 8.8.8.8 to whatever wifi network it connects.

Sign In or Register to comment.