ROG 3 charger and Aerocooler isn't working.

aiharanaoki911aiharanaoki911 Level 1
edited July 29 in ROG Phone 3

Hello. My ROG 3 won't charge unless I plug it while the ROG 3 is off. When I turn it on, the charging continues unless I unplug the charger and plug again. Basically, it isn't charging if the phone is on. My aerocooler isn't also working whether the phone is on or off. I tried ROG 1 charger, still not working. I used hairblower just in case there's a dust inside charging pin, but still it won't charge. It won't also connect to my ROG laptop even I use USB cable. Please help.

Comments

  • Hello!

    Would you please give us more information regarding your Phone?

    Please tell us some basic information before asking for help:

    1. Model Name:
    2. Firmware Version:
    3. Rooted or not:
    4. Frequency of Occurrence:
    5. APP Name & APP Version (If your issue relates to the app):

    In addition to the information above, please also provide as many details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

    ========================================

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.