System Update Failed

Please tell us some basic information before asking for help:

  1. Model Name: ASUS_I005DA (WW_I005D)
  2. Firmware Version: 18.0830.2101.87
  3. Rooted or not: Non-rooted
  4. Frequency of Occurrence: Often
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

My current Android version is Android 11 and I recently downloaded the latest build (Android 12) for my ASUS ROG Phone 5 on the official ROG website, but when I tried to manually install it, a message pops up saying "System update failed." The update package is on the root folder. I downloaded the file from both my PC and phone, then I tried restarting my phone, but every time I tried to install the update, the same message appeared. What have I done wrong? I need to use Android 12 because my phone has not detected any automatic updates for a while.


Sign In or Register to comment.