I downgraded From Windows 11 to Windows 10 and now I can't Install Screenpad 2.0

ggattipggattip Level 1
edited June 12 in ZenBook
  1. System: W10 64bit
  2. Battery or AC: both
  3. Model: Zenbook pro duo 15 OLED 11th gen
  4. Frequency of occurrence: Always
  5. Reset OS: Did it 3 times
  6. Screenshot or video: Error 1001

========================

Detailed description:

I downgraded my OS so it would run my video editing software smootthly (w11 has some color and freezing issues w/ adobe premiere and davinci) and now I cannot upgrade my screenpad to V2.0 and i'm stuck with 1.0.

I tried following the official FAQ install order for drivers, I tried installing V1.0 from scratch and then upgrading, I've tried everything I've found on multiple articles in this forum, and the i tried another 3 methods from other sources, nothing seems to work.

I just cannot believe that the only solution ASUS suggest is to reinstall w11 via technical support. Is w10 even compatible with V2.0? I am very lost and pretty angry, I just spent almost 3k USD to have a smooth workflow with the dials on the control center and now i can't even use it.

Please, I need to make this work.

Thanks for your help!

Comments

Sign In or Register to comment.