Original adapter and cable not working with ASUS Rog 5

amitkalani3amitkalani3 Level 1
edited June 29 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name:Asus Rog 5
  2. Firmware Version: WW_Phone-18.0840.2112.210
  3. Rooted or not: Non rooted
  4. Frequency of Occurrence: Permanent

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

Recently I am not able to charge my phone with the original adapter and cable.

I tested using samsung 25w charger which supports fast charging and it is able to charge it in around 2 hours.

Original Asus adapter can charge other samsung devices but not the rog phone 5. When connected it shows hypercharge but battery level remains same. I tried it on the side port but the issue remains.

I also recalibrated the battery by draining it to 0 and then fully charged it with a 10W adapter but still original adapter didn't work.

Many users have faced it and were given a solution in PM. I request to please provide me with a solution so i can hypercharge my phone with original adapter.

========================================

@Gustav_ASUS @Irene2_ASUS

Comments

  • Also I have already reset my device which didn't help.

  • FunBike31FunBike31 Level 4

    Important information is missing, the Rog 5 comes with a 65w or 30w charger depending on the country.

    The cable that comes with the 65w is usb-c/usb-c, it is of good quality and this type of connection is usually not a problem.


    I don't know the one delivered with the 30w, usb-c charger side, usb-a?

    The usb-a connector is more of a problem than the usb-c, usb-a makes bad contact over time, on the charger side and/or on the cable side.


    You don't describe if you did any cable cross testing, what you describe sounds very much like a bad cable contact.

    Be careful, a cable can work very well with a phone that requires less than 30w and not at all with a request of 30w and +


    The bottom port works randomly depending on the chargers, use the middle one for your tests

    There is also a difference in dialogue when you plug in the cable with the screen on!!!! and the screen off, turn off the screen, plug in the cable and turn on the screen for your tests.

    Go to the battery manager and see if the phone offers normal, slow or hyper-slow charging with the ASUS charger, if it does not offer you the 3 options, repeat the test by changing the cable.

    Remove the chargers for 5 min from the mains then reconnect them, it is possible that there is a blockage on a protocol

  • randiahmrandiahm Level 1

    This Morning I Have A Same Problem Did You Find Any Solution ? 23 May 2022

  • Hi amitkalani3,

    Trying to figure out a solution here, will get back. For quick solution can you visit the nearest service center?

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.