Kunai 3 Gamepad won't turn on unless plugged in

OgghyOgghy Level 2
edited May 11 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: Kunai 3 Gamepad
  2. Firmware Version: 3.3.3 & 3.1.0
  3. Rooted or not: not
  4. Frequency of Occurrence: Dead when unplugged
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

My warranty is already over. And i don't know how to troubleshoot the problem. So the controller is turn on when i press the power button long enough but it's turn off immediately after i remove my finger from the power button. It worked perfectly when i plugged in tho. Is it because the IC is already weaken or something's wrong with the battery ? I need an answer asap.

And btw sometimes it worked for 30 minutes with wireless mode. But it shutdown and I can't turned it on again. It's weird.

Comments

This discussion has been closed.