Rog Phone 5 loses service at random times and places.

WiLd256WiLd256 Level 1
edited April 27 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: Rog Phone 5
  2. Firmware Version: Current firmware 31.0810.1226.67, problem occurred on firmware 18.0840.2201.226
  3. Rooted or not: No
  4. Frequency of Occurrence: Everyday
  5. APP Name & APP Version (If your issue relates to the app): Mobile service

========================================

It really seems like one issue after another for this phone for me. I don't know if I'm just unlucky, or if the phone is just bad. I've had this phone for about 3 months now and randomly one morning, I see that my phone lost over 25% battery overnight while idle and that my phone no longer had service. The strange part is that the moment I exited my bedroom or went outside my phone suddenly had service again. I just assumed that somehow my room had turned into a blind spot, even though for the last few weeks this problem didn't exist. However, even stranger, the entire time I spent in school, my phone was at full bars, and by the time I came home, my phone would have good service anywhere inside my house, even though this morning, service was nonexistent in my room and my downstairs floor. At this point, I thought the issue had been resolved, only for the exact same scenario to occur again the next day. I would have no service inside the house in the morning, leave for school, come back and enjoy full service for the rest of the day until I went to bed and the service would cut out again. I know this isn't a sim problem, nor is it a problem with my house, or with my carrier AT&T, seeing as how both my parent's iPhones work perfectly, and my iPhone SE, a phone from six years ago also worked perfectly after inserting the sim. I've already tried multiple factory resets, reinserting the sim, and the classic toggling airplane mode and the issue persists.

This issue occurred about two weeks ago, and the reason why I held off writing this for so long is that I assumed the issue would fix itself. The problem came out of nowhere, so I hoped that the solution would also come out of nowhere. Also, the fact that I would get service for a majority of the day up until around 11:30 did lessen the pain a little bit. But as of today, my phone has no service anywhere inside my house, except for specifically the table inside my kitchen, and even then I'm only getting one or two bars. This entire day has been a massive pain in the ass, as I missed 3 very important calls, without even knowing I got called in the first place. This is unacceptable for a flagship phone, I shouldn't be forced to use my phone in one specific spot in my house. The fact that I am now forced to use a phone from over half a decade ago is inexcusable. What did I spend 700 dollars for? I am currently on android 12, but the issue had started in android 11 on firmware 18.0840.2201.226. Updating the firmware to the most recent version has fixed nothing. I will check again tomorrow morning to see if the problem has been fixed, but I doubt it will. I am trying to hold off on going to a service center. Not only because the nearest service center is 42 minutes away by car, but also because many other users reported their phones getting worse after visiting(worse battery, worse performance, overheating, etc), or the problem not being resolved at all. I also don't want to be left with an iPhone SE for the next month. Please, I have been tearing my hair out every day for the last 2 weeks. I just don't understand why this is an issue.

Comments

This discussion has been closed.