Twinview dock no display

RazgrizRazgriz Level 2
edited April 12 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: rog phone 3
  2. Firmware Version: 18.0410.2201.196
  3. Rooted or not: not
  4. Frequency of Occurrence: always
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

i just want to use my twinview after one or two months not using it, but i found it wont show display..

volume button n headset jack works, power button not, n when i close it wont lock my phone..

there is notification "charging device via usb" or something like that..

no display/charging menu, no vibration when connected, no twinview dock on hardware info..

i use twinview dock II from my old rog phone II btw..


@Anders_ASUS @Gustav_ASUS , sorry for tagging u, guys..

i really need ur help, n i hope this is just a bug on firmware because for last 2 months we got some updates, right?

i tried to search for this issue too, i got this same issue thread in a11 beta forum n that is because its in early beta ver which is mobile desktop dock n twinview dock is still not supported..

thx..

Tagged:

Comments

  • BPMBPM Level 2

    It sounds like it could be the result of a firmware update being needed, or a failed update that happened previously? Not sure how to test things on the Dock.

    Somewhat related: I had just bought another TwinView Dock 3 off of eBay (still in original shrinkwrap) after I broke my first one (it slipped out of my hands and cracked the screen). As it was never used, it needed a firmware update when I first connected it to my phone. Since it's working fine after that update, my best guess is yours had a botched update.

  • RazgrizRazgriz Level 2

    Is yours works fine now with latest phone update? Mine works fine before, one or two months ago..

    N yes, iirc update for twinview n any other accesories is only once when first connected to phone, no any update until now..cmiiw


    I always charge it to full whenever i want to store it again..Yesterday when i try it, i though maybe battery drained?

    I try to charge n it shown red led which is charging, but after charging a while n try to connect it again, it still wont show anything..


    Thx for suggestion tho..I hope mine not broke or else..I dont have any other phone or twinview to try..😑

  • firmware bug?? sorry i dont have twindock...

  • RazgrizRazgriz Level 2

    I really hope its just phone's firmware bug, not hardware issue..

  • BPMBPM Level 2

    Yeah, I just got it in the mail a couple of days ago. I'm assuming it was still using the original firmware since it was still in the original shrinkwrap. My phone is on the .196 update, too. It took awhile to update the TwinView Dock, which is why I'm assuming the age of the firmware.

    Hopefully, ASUS has some way to troubleshoot it, though.

  • RazgrizRazgriz Level 2

    Hmmmm..I try to charge for maybe 2 hrs n i dont see it go full, bottom side not even warmed while charging..

    Should i try to open it n disconect its battery to "reset" it? But i dont find any tutorial how to open it..

    Yes, there is screws under those rubber..but idk if there is any more hidden screw elsewhere like under label etc.. 😑

  • RazgrizRazgriz Level 2

    Welp, already open it up, unplug n plug battery again, but still not working 😂


  • RazgrizRazgriz Level 2

    Holy . . . . .

    Its working now! 😂😂😂


    But something strange tho..charging from twinview so slow, always below 1 ampere..when i plug my charger to twinview, it goes up more than 2 ampere.. 😑

  • RazgrizRazgriz Level 2

    After reassembly it, i wont work again..duh..😑

    I try to redo what i did before but still not working..

    But at least now i know this is hardware failure..

  • BPMBPM Level 2

    Ouch... I wonder if there's an issue with a ribbon cable? If it's working when disassembled and then stops when reassembled, that makes me think there's a cable issue and the pressure of the casing is causing a short. Dunno, just throwing ideas out there.

    If it's been less than a year since you purchased it, it might still be under warranty. If not, may just want to get a new one. The one I just got off eBay was from a seller in the UK for about £106 (about $138 USD).

    Aside from that, could look into possibly replacing parts. Before I decided to buy a new TwinView, I was looking around for a replacement screen. I had found some random site selling parts, and wanted $150 for the screen alone. I had also found a TwinView 2 screen on AliExpress for about $80 (not 100% sure if that'd work, since the TwinView 2 and 3 are extremely similar, only differences being button color and screen refresh rates).

  • RazgrizRazgriz Level 2

    Yup, i tried to plug-unplug all cable, but still not work..It work sometimes, but after i detach it from phone then it wont work again..kinda random, i cant replicate what i did before to make it work..


    Its already out of warranty, more than 2 years..


    I'd like to buy replacement parts, but i still dont know where the problem is.. 😂

    Considering to buy new one tho..but i still curious what make it broke, so i can be more careful with new one..even tho i always careful with this but still broke suddenly.. 😑

This discussion has been closed.